Kibana 6.1-Login is currently disabled. Administrators should consult the Kibana logs for more details


#1

Hi everyone,
I installed for the first time the stack elk (version 6.1.0) on windows following the guide.

After running the x-pack installation I added the following line in the kibana.yml and elasticsearch.yml file: # xpack.security.enabled: false.
But when I open kibana the login form is disabled:
Cattura

and I get the following message:

  log   [21:05:42.568] [warning][security] Generating a random key for xpack.sec
urity.encryptionKey. To prevent sessions from being invalidated on restart, plea
se set xpack.security.encryptionKey in kibana.yml
  log   [21:05:42.574] [warning][security] Session cookies will be transmitted o
ver insecure connections. This is not recommended.
  log   [21:05:42.606] [error][status][plugin:searchprofiler@6.1.0] Status chang
ed from uninitialized to red - [security_exception] missing authentication token
 for REST request [/_xpack], with { header={ WWW-Authenticate="Basic realm=\"sec
urity\" charset=\"UTF-8\"" } }
  log   [21:05:42.613] [error][status][plugin:ml@6.1.0] Status changed from unin
itialized to red - [security_exception] missing authentication token for REST re
quest [/_xpack], with { header={ WWW-Authenticate="Basic realm=\"security\" char
set=\"UTF-8\"" } }
  log   [21:05:42.698] [error][status][plugin:tilemap@6.1.0] Status changed from
 uninitialized to red - [security_exception] missing authentication token for RE
ST request [/_xpack], with { header={ WWW-Authenticate="Basic realm=\"security\"
 charset=\"UTF-8\"" } }
  log   [21:05:42.704] [error][status][plugin:watcher@6.1.0] Status changed from
 uninitialized to red - [security_exception] missing authentication token for RE
ST request [/_xpack], with { header={ WWW-Authenticate="Basic realm=\"security\"
 charset=\"UTF-8\"" } }
  log   [21:05:42.731] [info][status][plugin:grokdebugger@6.1.0] Status changed
from uninitialized to green - Ready
  log   [21:05:42.740] [info][status][plugin:dashboard_mode@6.1.0] Status change
d from uninitialized to green - Ready
  log   [21:05:42.744] [error][status][plugin:logstash@6.1.0] Status changed fro
m uninitialized to red - [security_exception] missing authentication token for R
EST request [/_xpack], with { header={ WWW-Authenticate="Basic realm=\"security\
" charset=\"UTF-8\"" } }
  log   [21:05:42.778] [info][status][plugin:apm@6.1.0] Status changed from unin
itialized to green - Ready
  log   [21:05:42.782] [info][status][plugin:license_management@6.1.0] Status ch
anged from uninitialized to green - Ready
  log   [21:05:42.791] [info][status][plugin:console@6.1.0] Status changed from
uninitialized to green - Ready
  log   [21:05:42.806] [info][status][plugin:metrics@6.1.0] Status changed from
uninitialized to green - Ready
  log   [21:05:43.887] [info][status][plugin:timelion@6.1.0] Status changed from
 uninitialized to green - Ready
  log   [21:05:43.893] [info][listening] Server running at http://localhost:5601

  log   [21:05:48.648] [warning][license][xpack] License information from the X-
Pack plugin could not be obtained from Elasticsearch for the [data] cluster. [se
curity_exception] missing authentication token for REST request [/_xpack], with
{ header={ WWW-Authenticate="Basic realm=\"security\" charset=\"UTF-8\"" } } ::
{"path":"/_xpack","statusCode":401,"response":"{\"error\":{\"root_cause\":[{\"ty
pe\":\"security_exception\",\"reason\":\"missing authentication token for REST r
equest [/_xpack]\",\"header\":{\"WWW-Authenticate\":\"Basic realm=\\\"security\\
\" charset=\\\"UTF-8\\\"\"}}],\"type\":\"security_exception\",\"reason\":\"missi
ng authentication token for REST request [/_xpack]\",\"header\":{\"WWW-Authentic
ate\":\"Basic realm=\\\"security\\\" charset=\\\"UTF-8\\\"\"}},\"status\":401}",
"wwwAuthenticateDirective":"Basic realm=\"security\" charset=\"UTF-8\""}

can someone help me?

I would like to disable authentication via x-pack. What can I do?


(Tim Vernum) #2

It appears that authentication is still enabled on you Elasticsearch cluster.

Did you restart the cluster after you changed the configuration?

What does this command produce?

curl 'http://localhost:9200/'

(Tim Vernum) #3

Did you include that # in the configuration file?
That makes the whole line into a comment, so it achieves nothing. The config should be

xpack.security.enabled: false

#4

Hi Tim,
I forgot to remove # in the kibana.yml file, I removed it and after restarting the cluster, everything works correctly.

thank you so much


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.