Logstash 5.0 - Kafka Input installation issue

Using Logstash 5.0 Alpha. Trying to install the kafka input plugin returns this error:

bin/logstash-plugin install --version 3.0.0.beta3 logstash-input-kafka
Validating logstash-input-kafka-3.0.0.beta3
Installing logstash-input-kafka
Plugin version conflict, aborting
ERROR: Installation Aborted, message: Bundler could not find compatible versions for gem "logstash-core":
In snapshot (Gemfile.lock):
logstash-core (= 5.0.0.alpha3)

In Gemfile:
logstash-input-kafka (= 3.0.0.beta3) java depends on
logstash-core (< 3.0.0, >= 2.0.0) java

logstash-core (= 5.0.0.alpha3) java

This is my first time with Logstash 5.0. One of the reasons for trying the Alpha out is because of it's support for Kafka 0.9 and SSL.

How do I proceed from here?