Plugin version conflict with Logstash 2.4 (logstash-input-kafka and logstash-output-kafka)


(Ryan Yacyshyn) #1

Hi all,

I want to use Kafka with Logstash. I've installed Logstash 2.4 and Kafka 0.10.0.1. According to the docs, I need to use version 5.0.0 of the logstash-input-kafka and logstash-output-kafka plugins.

When I try to install either one, I get a plugin conflict error:

Validating logstash-output-kafka-5.0.0
Installing logstash-output-kafka
Plugin version conflict, aborting
ERROR: Installation Aborted, message: Bundler could not find compatible versions for gem "logstash-core-plugin-api":
  In snapshot (Gemfile.lock):
    logstash-core-plugin-api (= 1.60.4)

  In Gemfile:
    logstash-output-udp (< 3.0.0) java depends on
      logstash-core-plugin-api (~> 1.0) java

    logstash-output-udp (< 3.0.0) java depends on
      logstash-core-plugin-api (~> 1.0) java

    logstash-output-udp (< 3.0.0) java depends on
      logstash-core-plugin-api (~> 1.0) java

<...more listings here...>

    logstash-output-udp (< 3.0.0) java depends on
      logstash-core-plugin-api (~> 1.0) java

    logstash-output-udp (< 3.0.0) java depends on
      logstash-core-plugin-api (~> 1.0) java

    logstash-output-kafka (= 5.0.0) java depends on
      logstash-core-plugin-api (~> 2.0) java

    logstash-core-plugin-api (= 1.60.4) java

Running `bundle update` will rebuild your snapshot from scratch, using only
the gems in your Gemfile, which may resolve the conflict.

I'm running this on ubuntu 14.04.

Anyone know how I can fix this?

Thanks,
Ryan


(Joe Lawson) #2

The docs indicate that this should work. I would submit a bug to
https://github.com/logstash-plugins/logstash-output-kafka and ask if one
needs to go in to https://github.com/elastic/logstash


(Ryan Yacyshyn) #3

Ok, posted an issue on https://github.com/logstash-plugins/logstash-output-kafka.


(Rohit Singh) #4

Is the issue resolved. If yes can you please summarize the steps


(Ryan Yacyshyn) #5

This issue is resolved. I needed to install Kafka versions 5.0.1 or higher. I installed 5.0.4 and it worked fine for both input and output plugins. https://github.com/logstash-plugins/logstash-output-kafka/issues/91


(system) #6