Logstash fails to start with central configuration(bug in 6.0.0-beta1)


(Arthur Gimpel) #1

I have Elasticsearch6.0.0beta1 and logstash6.0.0beta1 installed on my Mac. Both have x-pack plugin installed.
My Elasticsearch.yml contains "xpack.security.enabled: false" and everything works. When trying to start Logstash with central configuration, it won't start since I don't use pack security.

Logstash.yml:
xpack.management.enabled: true
xpack.management.elasticsearch.url: "http://localhost:9200/"
xpack.management.logstash.poll_interval: 5s
xpack.management.pipeline.id: ["local_cloudtrail"]

Message on runtime:
[2017-08-10T19:45:26,911][FATAL][logstash.runner ] An unexpected error occurred! {:error=>#<ArgumentError: You must set the password using the "xpack.management.elasticsearch.password" in logstash.yml>


(Mark Walkom) #2

The centralised management feature is part of our Gold/Platinum level functionality, so the expectation there is that the cluster would have authentication enabled to protect access to the configs.

It's not mentioned in the docs though and we will get that updated accordingly.


(Arthur Gimpel) #3

Thanks for your reply. Would it be documented, or modified? Not all subscription users have authentication.


(Mark Walkom) #4

Yes they do, see https://www.elastic.co/subscriptions


(Arthur Gimpel) #5

I meant that not all subscriptions users are using pack security, like I did now :slight_smile:


(Mark Walkom) #6

Oh right, not sure why you'd not be using it!


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.