Management expects password after disabling security in X-Pack 6.0.0-beta2


(John Sobanski) #1
  • Expected Behavior: Disabling X-Pack security on Elasticsearch obviates the need for a Logstash management password
  • Observed Behavior: Logstash complains that it needs a management password
  • I installed X-Pack on Elasticsearch, Kibana and Logstash (All running 6.0.0-beta2).
  • My elasticsearch.yml includes the following line:
 xpack.security.enabled: false

According to the X-Pack documentation, I do not need a password if I disable security:

xpack.management.elasticsearch.username and xpack.management.elasticsearch.password
If your Elasticsearch is protected with basic authentication, these settings provide the username and password that the Logstash instance uses to authenticate for accessing the configuration data. The password for the elastic user is whatever password you specified when you installed X-Pack and set up authentication.

My Elasticsearch does not use basic authentication, so I would assume I do not need to set a password here.


(John Sobanski) #2

The log message follows

[2017-09-07T18:36:35,335][FATAL][logstash.runner          ] An unexpected error occurred! {:error=>#<ArgumentError: Setting "xpack.security.enabled" hasn't been registered>, :backtrace=>["/usr/share/logstash/logstash-core/lib/logstash/settings.rb:32:in `get_setting'", "/usr/share/logstash/logstash-core/lib/logstash/settings.rb:65:in `set_value'", "/usr/share/logstash/logstash-core/lib/logstash/settings.rb:84:in `block in merge'", "org/jruby/RubyHash.java:1343:in `each'", "/usr/share/logstash/logstash-core/lib/logstash/settings.rb:84:in `merge'", "/usr/share/logstash/logstash-core/lib/logstash/settings.rb:133:in `validate_all'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:277:in `execute'", "/usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/clamp-0.6.5/lib/clamp/command.rb:67:in `run'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:232:in `run'", "/usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/clamp-0.6.5/lib/clamp/command.rb:132:in `run'", "/usr/share/logstash/lib/bootstrap/environment.rb:71:in `<main>'"]}

(Tim Vernum) #3

The documentation is a bit unclear on this.

I believe you need to set xpack.management.elasticsearch.username to a blank value.
It defaults to logstash_system so if you don't set a password it will act as if you have specified a user but no password.


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.