Logstash-input-jms real slow or losing messages


#1

I have set up the plug-in to subscribe to an AMQ topic and send the messages to stdout (just for initial testing). I have separate Java client subscribing to the same topic and I can see that the message rate is about 3 per second. But logstash-input-jms is printing maybe 1 message once a minute or even longer. I tried increasing the number of threads from the default of 1 to 5, made no difference. Tried running it on Windows and Centos 6, same performance. I haven't looked to see if it is just slow or is missing messages; if it was slow it would hold up all the other AMQ clients on this topic, eventually, but that doesn't seem to be happening. Any ideas?
It is logstash 6.2.2

The configuration file and YAML files are here:

input {
  jms {
     id => "rb-activity"
     include_header => false
     include_properties => false
     include_body => true
     use_jms_timestamp => false
     destination => "RB-ACTIVITY"
     pub_sub => true
     yaml_file => "rb-jms.yml"
     yaml_section => "activemq"
  }
}

output {
#    elasticsearch {
#        hosts => [ "recap02:9200" ]
#        index => "rbactivity-%{+YYYY.MM.dd}"
#    }
    stdout {
         codec => rubydebug
    }
}

YAML FIle

# Active MQ Centralized Broker
activemq:
  :factory: org.apache.activemq.ActiveMQConnectionFactory
  :runner: async
  :broker_url: tcp://myhost:61616
  :require_jars:
    - c:\tools\logstash-6.2.2\amqlib\activemq-all-5.15.0.jar

(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.