Logstash input jmx does'nt work in logstash 5.0.0


(anas) #1

when installing plugin (/logstash-plugin install logstash-input-jmx) i have the folowing error :

.
.
.
Running bundle update will rebuild your snapshot from scratch, using only
the gems in your Gemfile, which may resolve the conflict.
Bundler could not find compatible versions for gem "logstash":
In Gemfile:
logstash-input-jmx (>= 0) java depends on
logstash (< 2.0.0, >= 1.4.0) java
Could not find gem 'logstash (< 2.0.0, >= 1.4.0) java', which is required by gem 'logstash-input-jmx (>= 0) java', in any of the sources.


(Tal Levy) #2

looks like the fix to make it compatible with 5.0.0 was worked on, but never published.

I will work on publishing this soon and update you when version 3.0 of the plugin is ready


(anas) #3

Many thanks,

There is any nightly build of this plugin?


#4

This might help too, if you download the latest build from git and make the changes from the link, it should get you up and running.


(Tal Levy) #5

latest version of the plugin: 3.0.0 should fix this!


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.