Logstash JMS Input Plugin

Does Logstash-Input-Jms plugin need a specific version of Logstash? I am using Logstash 1.4.2. And I'm struggling to get this plugin to work.

Can anyone help me with the configuration?

I copied jms.rb into /lib/logstash/inputs/
I copied jms_spec.rb /spec/inputs
Copied the Gemfile, logstash-input-hms.gemspec, Rakefile into the main directory.

What am I missing?

The 1.4 branch of Logstash is officially deprecated and unsupported. You should upgrade to at least 1.5.x, if not the most recent, 2.2 branch.

So the jms plugin wouldn't work with 1.4.2?

Assuming I upgrade to 1.5.x or 2.2, I still am lost with regard to the configuration. Is jms plugin shipped with 1.5.x or 2.2? Or do I have to install it separately?

Right now, with 1.4.2, I get this error.

With the newer versions, you install the plugin (if not bundled—which it might not be) by changing to your logstash directory and running bin/plugin install logstash-input-jms (presuming that's the correct name for it). This requires network access, as it pulls from rubygems.org

When I try doing it, I get this error. Can you help me with it?

It appears that the JMS input requires Logstash v2.0 or greater.