Logstash not listening remote tcp port on Azure windows VM


(Ravindra Barapatre) #1

I have deployed following components on Azure VM.

  1. logstash 5.4.0
  2. ElasticSearch 5.4.0
  3. kibana 5.4.0

It is running locally perfectly for TCP input plugin on VM.

input {
  tcp {
	 port => 52811
 host => "0.0.0.0"
  }
}
output {
  elasticsearch { hosts => ["127.0.0.1:9200"] }
  stdout { codec => rubydebug }
}    

but when I am trying call logstash from my local machine using NLog with config.

<nlog xmlns="http://www.nlog-project.org/schemas/NLog.xsd"
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
  <targets>
    <target name="network" xsi:type="Network" address="tcp://{hostname}:52811" layout="${level} ${logger} ${message}${newline}" />
  </targets>
  <rules>
     <logger name="*" minlevel="Trace" writeTo="network" />
  </rules>
</nlog>

I have set firewall setting for tcp port 52811 on VM.

It is not working..

Please help me..


(system) #2

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.