Looks like you don't have any metrics indices

Hi there,

I'm trying to set up a monitoring system with ELK.
I deploy Beats on my infra
Beats output to Logstash server
Logstash server output to Elasticsearch Server
And I want to visualize my data with Kibana.

On Kibana, I can discover my Data:

My problem is when I try to use the metric (or log) app:
I get the "Looks like you don't have any metrics indices." message, and I don't understand why

Logstash (running in docker) uses the following /usr/share/logstash/pipelines.yml

- pipeline.id: beats
path.config: "/usr/share/logstash/pipeline/beats.conf"

and the /usr/share/logstash/pipeline/beats.conf

input {
  beats {
    type => "beats"
    port => 5044
    tags => ["beats", "filebeat"]
  }
}

output {
  stdout {
    codec => rubydebug
  }
  elasticsearch {
    hosts => ["elasticsearch:9200"]
  }
}

And here is my metricbeat.yml file

name: " {{ ansible_hostname }} "

metricbeat.config.modules:
  path: ${path.config}/modules.d/*.yml
  reload.enabled: false

setup.template.settings:
  index.number_of_shards: 1
  index.codec: best_compression

setup.kibana:
  host: "{{ kibana_host }}:{{ kibana_port }}"

#output.elasticsearch:
  #hosts: ["{{ elasticsearch_host }}:{{ elasticsearch_port }}"]

output.logstash:
  hosts: ["{{ logstash_host }}:{{ logstash_port }}"]
  index: metricbeat

processors:
  - add_host_metadata: ~
  - add_cloud_metadata: ~
  - add_docker_metadata: ~
  - add_kubernetes_metadata: ~

What do I miss?

Because pipeline is yml, indentation is important..

Try this:

- pipeline.id: beats
  path.config: "/usr/share/logstash/pipeline/beats.conf"

Hi thanks for your answer!

I tried it but didn't fix the problem.
I fixed it with the following beats.conf file:

input {
  beats {
    type => "beats"
    port => 5044
  }
}

output {
  stdout {
    codec => rubydebug
  }
  elasticsearch {
    hosts => ["elasticsearch:9200"]
    manage_template => false
    index => "%{[@metadata][beat]}-%{[@metadata][version]}-%{+YYYY.MM.dd}"
    document_type => "%{[@metadata][type]}"
  }
}

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.