Machine leaning Option not showing up in kibana

Hi Team ,

I am unable to Machine learning option in Kibana , though I see it in my spaces .
I tried enabling and Disabling , but no luck .

Xpack is enabled for my user account .

Any suggestion ?


What is your license level on the stack ? Obtain a license that includes the machine learning features. By default, when you install Elastic Stack products, they apply basic licenses with no expiration dates. To view your license in Kibana, go to Management and click License Management . For more information about Elastic license levels, see
You can start a 30-day trial to try out all of the platinum features, including machine learning features. Click Start trial on the License Management page in Kibana. Platinum License supports:

Advanced functionality. Around the clock support.

Everything in Gold plus:

  • Advanced Elastic Stack security features
  • Machine learning
  • Cross-cluster replication
  • 24/7/365 support
  • And more


Hi Rashmi ,

Thanks for responding on this , We have gold license and machine learning option is visible for rest of my team members .


Hi Joy,
I would check the permissions of the user whom you have logged in as into Kibana. Might be not having enough permissions to access ML. Machine learning requires a commercial license and is generally not available when using the basic license, but since you have gold, that wouldn't matter.

Can you please share what roles does this user have here? We can figure out further what's wrong then.


Thank you Rashmi , Issue is now fixed .. This was basically role not mapped properly.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.