Elastic superuser: You need permission to access Machine Learning

Hello,
suddenly, I'm not user when (perphaps after change ES cluster name) I cant load Machine Learning tab (logged in Kibana with superuser elastic). Kibana says:

You need permission to access Machine Learning

You must have the privileges granted in the kibana_user and machine_learning_user roles.
Your system admin can set these roles on the Management User page.

For test purpose, I've create another user with kibana_user and machine_learning_user roles only with not success.

All index (security-v7 too) seems to be all.

Can anyone help me?

Thank you!

1 Like

I am also looking for resolution to this issue. Even logging in as superuser I am unable to access the ML functionality with the BASIC license.

Thank you.

@sergiodcm00 This issue on Github appears to be the same problem we're experiencing.

Hi
Is there any resolution - I am facing the same issue.

Machine learning requires a commercial license and is generally not available when using the basic license.

Can we get some trail license to test !

Yes, you can enable that through Kibana.

It's a fix, but isn't in any revision yet.

Hi @Christian_Dahlqvist, @mvenkat_in -
With a Basic license we should be able to access Data Frames and Visualizer in ML. This appears to be a bug and has been fixed here: https://github.com/elastic/kibana/pull/41876, though not in any release yet.

Hi
Any Idea how to access ML at present without waiting for this bug... I am using Kibana 7.3. A demo is scheduled and would want to test this feature.
Thanks