Machine Lerning Tab giving error

Hello, After i seperated my ml nodes, i realised my machine learning tab at kibana not working as expected.

Probably it is about some other reason but couldn't find out how to fix this.
I don't know whether something is deleted.

I disabled ml on each ml node restarted, and rechanged them to true and restarted again to see if any change. "xpack.ml.enabled: true"

When i enter ML tab i see;

An error occurred getting the anomaly detection jobs list.
Incorrect HTTP method for uri [/_ml/calendars/] and method [GET], allowed: [POST]

An error occurred getting the data frame analytics list.
no handler found for uri [/_ml/data_frame/analytics/_all?size=1000] and method [GET]

Checked from dev_tools:
POST _ml/datafeeds/_all/_stop
"error" : "no handler found for uri [/_ml/datafeeds/_all/_stop?pretty=true] and method [POST]"

Another thing i got stuck is , my node.ml:true and xpack.ml.enabled: true on "ML" nodes but when i check from "GET _xpack".

   "ml" : {
  "available" : true,
  "enabled" : false,
  "native_code_info" : {
    "version" : "N/A",
    "build_hash" : "N/A"
  }

In addition to setting
xpack.ml.enabled: true

You also need to make sure the node has the ml role assigned to it:
node.roles: [ ml ]

See: Machine learning settings in Elasticsearch | Elasticsearch Reference [7.11] | Elastic

Have you done this?

I am pretty sure you have xpack.ml.enabled: false on the node that Kibana is connected to.

You need xpack.ml.enabled: true on all ML nodes, all master eligible nodes and all nodes that a client (e.g. Kibana) might call an ML API on. By far the easiest way to ensure this is just to have xpack.ml.enabled: true on every node in the cluster when you are using ML in any way.

Hello Rich,
Of course node.role is set.

node.data: false
node.master: false
node.ingest: false
node.ml: true
xpack.ml.enabled: true

Hello Droberts,
It is possible my kibana.yml hosts lists include all elastic hosts 12 machines but only 3 is ml and xpack.ml.enabled: true is only on ml nodes. I will make the changes on others and check again.