Make command fails when trying to compile new metricset in metricbeat

I installed all the dependencies for creating new metricset with metricbeat(include Bison\Yacc).
After running the "Make create-metricset" and "Make collect" successfully I tried to compile the beat with the "Make" command but it fails with the following errors: warning: implicit declaration of function ‘yyerror’; did you mean ‘yyerrok’? [-Wimplicit-function-declaration] ../vendor/ At top level: ../vendor/ error: unknown type name ‘func’ func TokenName(c int) string { ^~~~ ../vendor/ error: unknown type name ‘c’ func TokenName(c int) string { ^ <builtin>: recipe for target '../vendor/' failed make: *** [../vendor/] Error 1 rm ../vendor/

Can you try to run "make update-yacc-vendor"?

Thank you! It did the work and fixed my problem!

Is this a new issue @mtojek? I was trying to build filebeat from the master branch, and I hit the same issue. I don't recall running into this issue in the past.

I have to mention that I had to install yacc/bison manually before I ran the "make" command

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.