Mapping Error in Kibana 5.6.x


(Rodrigo Porto) #1

Hi everyone,

We have a problem after an upgrade from Elasticsearch and Kibana 5.4.2 to 5.6.0. We updated kibana index in order to have compatibility with Elastic 6.x by the new utility in Kibana.

After that, we got the next exception:

[2017-09-21T16:37:07,992][DEBUG][o.e.a.a.i.m.p.TransportPutMappingAction] [name_machine] failed to put mappings on indices [[[.kibana-6/txg1pewhRB-OTDp4_c6Uew]]], type [url]
java.lang.IllegalArgumentException: [url] is defined as a field in mapping [url] but this name is already used for an object in other types

We tried to upgrade 5.6.1 and the same problem happens. Kibana doesn't work however Elastic seems fine.

Any idea?

Thanks in advance


(Tyler Smalley) #2

There is an issue where the original Kibana index was created without dynamic mapping disabled. This breaks the compatibility fallback. We're currently working on a fix for this you would be able to run. Apologies for any inconvenience.


(Rodrigo Porto) #3

Hi Tyler,

Thanks for your answer :slight_smile:. Is there any way to fix it easily?

Thanks in advance,

Regards


(Park Wonwoo) #4

I also occurred this error.

you must upgrade to 5.6.1

and fix it refer below url


(Rodrigo Porto) #5

Hi Park,

We upgraded to Elasticsearch and Kibana 5.6.1 and this kind of error continues. Moreover, in the post which you sent me, Benpoizin has the same error (at the end of the post).

Regards


(Ben Polzin) #6

Thanks, @RdrgPorto. My updated/detailed post is over here.. But it's the exact same issue you describe in this thread.

@tsmalley, any ETA on the fix? I'd like to get this in before the weekend.


(Ben Polzin) #7

Fixed mine using the instructions in this thread.


(Rodrigo Porto) #8

Hi,

Thanks Ben :smile: ,

Regards


(system) #9

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.