Maps not loading... some sort of CSP issue

Hi all

I'm using the elastic supplied dockerised version of Kibana, version 7.5.2 which is working fine for general elastic management. I'm having issues with the Map functions.

When I try and use/create a map I get a blank map.

In Chrome I get the below error

Unable to initialize map
Failed to construct 'Worker': Access to the script at 'blob:https://mydomain/72f464b4-b547-4266-9957-09f76a82cefb' is denied by the document's Content Security Policy.

In Firefox I get a blank page with the warning triangle showing road_map cannot be retrieved "Network error when attempting to fetch resource". The dev console Network tab shows the GET to is not completing with CSP under "transferred".

Both the kibana container (via curl) and my web browser can access the url. I've had a colleague try the website from a different machine and they get the same behaviour.

Is there anything I need to do to get the maps to show. I'm not a web developer by trade so I don't know if this is something i've missed in setup or an issue with the kibana docker image as supplied (or something else entirely).

In addition

If I disable CSP in Firefox, the maps do display. However at that point I do get a popup message
"your browser does not meet the security requirements for kibana."

As a workaround it's not ideal.

The error message seems to indicate that your browser is not supporting WebGL.What browser and version are you on?It's also possible that for your particular browser, WebGL support is turned off. Is there a proxy inbetween ?

cc @thomasneirynck


I've tried firefox 73.01 and chrome 80.0.3987.116. I've removed all plugins/addons to rule them out.

There is no proxy involved. If I disable security.csp.enable in the firefox console then the map displays along with a security warning .

After your comments I've also tried changing some of the webgl settings in firefox, but that doesn't seem to make any difference.

If it helps, I've cut the appropriate request out of a screenshot from the Firefox Dev Console. The first one shows the request failing when security.csp.enable is set to true. The request underneath that shows the request completing when security.csp.enable is set to false.

@thomasneirynck or @Aaron_Caldwell can you please help here?


hi @markbgale,

thanks for raising this issue. So both these errors so seem to refer to a generic CORS-loading issue.

That "unable to initialize map" is often related to WebGL, but given the error-message (can't load worker-script), we should be able to rule out it's a WebGL problem. Usually, the error message would say something more (e.g. "can't initialize WebGL-context" or something along those lines).

Could you try the following?

Go to Does the page load succesfully? This is a previewer-website that loads the map with CORS in your browser, similar to how Kibana would do it with the default settings.

If that works in both your browsers (FF and chrome), it's probably related to the Kibana install/configuration.

Hi Thomas

I can confirm that works fine in both Firefox and Chrome.

The kibana install I use is the docker image from

Are there any settings in there you recommend I adjust or is this something that will require an updated container?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.