Marvel behind Nginx and https


(J. Schulz) #1

Hi,

I have Nginx configured as reverse proxy to access elasticsearch over https

  • auth basic. As example

Unfortunately Marvel tries to connect to http://hostname/.

The affected code line is in
/usr/share/elasticsearch/plugins/marvel/_site/kibana/config.js

elasticsearch: "https://"+window.location.hostname+(window.location.port
!== '' ? ':'+window.location.port : ''),

should be

elasticsearch:
window.location.protocol+"//"+window.location.hostname+(window.location.port
!== '' ? ':'+window.location.port : '')

Cheers,
Jonny

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/b8f2d612-871c-43bc-aaf6-4a27bbd43d41%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #2