Marvel Sense is not working over https

Marvel Sense is not working, it hangs when it tried to connect to the
Elasticsearch API.The rest of Marvel seems to be working fine, as does the
Elasticsearch API if called directly.

I am using a freshly installed Elasticsearch 1.4.1 and the latest Marvel.

Elasticsearch is exposed on the internet over SSL as https://mydomain/.

When I profile the javascript in the browser, I can see that Marvel Sense
actually tries to make the calls to the API over http, even though the API
and Marval are using https. My Elasticsearch installation is not available
over the internet to anything other than https. I have nginx installed,
which passes the elasticsearch calls from 443 to 9200. Again this all works
fine when calling the Elasticsearch API or the plugins etc.

Any ideas?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/c1672223-3a03-48a2-bf12-90f7938fa12c%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Copy pasting from the relevant GitHub issue for future reference: (https://github.com/elasticsearch/elasticsearch/issues/8735)

In the next marvel release we will have automatic support for this. I wonder if things would work for you if enter https://mydomain/ in the server box of sense. It doesn't indeed listen to the config.js file of kibana.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/02107297-a29f-46b4-9532-51313551dbaf%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

A short note that the work around is not needed anymore with marvel 1.3.0.

Cheers,
Boaz

On Wednesday, December 3, 2014 7:11:07 AM UTC+1, Boaz Leskes wrote:

Copy pasting from the relevant GitHub issue for future reference: (
https://github.com/elasticsearch/elasticsearch/issues/8735)

In the next marvel release we will have automatic support for this. I
wonder if things would work for you if enter https://mydomain/ in the
server box of sense. It doesn't indeed listen to the config.js file of
kibana.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/014eaa20-7125-414e-905c-38d0c5ef1b89%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.