Marvel behind Nginx and https


(J. Schulz) #1

Hi,

I have Nginx configured as reverse proxy to access elasticsearch over https

  • auth basic. As example

Unfortunately Marvel tries to connect to http://hostname/.

The affected code line is in
/usr/share/elasticsearch/plugins/marvel/_site/kibana/config.js

elasticsearch: "http://"+window.location.hostname+(window.location.port !==
'' ? ':'+window.location.port : ''),

should be

elasticsearch:
window.location.protocol+"//"+window.location.hostname+(window.location.port
!== '' ? ':'+window.location.port : '')

Cheers,
Jonny

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/c536426a-36a6-4a24-888c-95ff0a4d053f%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Ivan Brusic) #2

Marvel was just announced today (to me at least), and there already is a
question/issue? :slight_smile: Let us know how it is working out.

I am assuming that the elasticsearch team has Marvel as a private repo,
which means you can't post issues.

--
Ivan

On Tue, Jan 28, 2014 at 7:45 AM, J. Schulz js.bloonix@gmail.com wrote:

Hi,

I have Nginx configured as reverse proxy to access elasticsearch over
https + auth basic. As example

Unfortunately Marvel tries to connect to http://hostname/.

The affected code line is in /usr/share/elasticsearch/
plugins/marvel/_site/kibana/config.js

elasticsearch: "http://"+window.location.hostname+(window.location.port
!== '' ? ':'+window.location.port : ''),

should be

elasticsearch: window.location.protocol+"//"+window.location.hostname+(window.location.port
!== '' ? ':'+window.location.port : '')

Cheers,
Jonny

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/c536426a-36a6-4a24-888c-95ff0a4d053f%40googlegroups.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQCmZM31%3DN6qa3XiLRCCm34M%2Bgq0Hn-qHth0jXPsEUg%3DSw%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(J. Schulz) #3

I know :wink:

@kimchy where to report bugs? On
http://github.com/elasticsearch/elasticsearch …?
@bloonix for now, best place is the google group:
https://groups.google.com/forum/#!forum/elasticsearch

Am Dienstag, 28. Januar 2014 16:51:39 UTC+1 schrieb Ivan Brusic:

Marvel was just announced today (to me at least), and there already is a
question/issue? :slight_smile: Let us know how it is working out.

I am assuming that the elasticsearch team has Marvel as a private repo,
which means you can't post issues.

--
Ivan

On Tue, Jan 28, 2014 at 7:45 AM, J. Schulz <js.bl...@gmail.com<javascript:>

wrote:

Hi,

I have Nginx configured as reverse proxy to access elasticsearch over
https + auth basic. As example

Unfortunately Marvel tries to connect to http://hostname/.

The affected code line is in /usr/share/elasticsearch/
plugins/marvel/_site/kibana/config.js

elasticsearch: "http://"+window.location.hostname+(window.location.port
!== '' ? ':'+window.location.port : ''),

should be

elasticsearch: window.location.protocol+"//"+window.location.hostname+(window.location.port
!== '' ? ':'+window.location.port : '')

Cheers,
Jonny

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/c536426a-36a6-4a24-888c-95ff0a4d053f%40googlegroups.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/897ac725-e037-4f77-9541-ec56a90b00bf%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Ivan Brusic) #4

Not sure what you are trying to accomplish by applying Twitter conventions
on a mailing list. :slight_smile:

Shay has not been on the mailing list in a long time. Eventually someone
from elasticsearch will read your email.

--
Ivan

On Tue, Jan 28, 2014 at 7:54 AM, J. Schulz js.bloonix@gmail.com wrote:

I know :wink:

@kimchy where to report bugs? On
http://github.com/elasticsearch/elasticsearch ...?
@bloonix for now, best place is the google group:
https://groups.google.com/forum/#!forum/elasticsearch ...

Am Dienstag, 28. Januar 2014 16:51:39 UTC+1 schrieb Ivan Brusic:

Marvel was just announced today (to me at least), and there already is a
question/issue? :slight_smile: Let us know how it is working out.

I am assuming that the elasticsearch team has Marvel as a private repo,
which means you can't post issues.

--
Ivan

On Tue, Jan 28, 2014 at 7:45 AM, J. Schulz js.bl...@gmail.com wrote:

Hi,

I have Nginx configured as reverse proxy to access elasticsearch over
https + auth basic. As example

Unfortunately Marvel tries to connect to http://hostname/.

The affected code line is in /usr/share/elasticsearch/plugi
ns/marvel/_site/kibana/config.js

elasticsearch: "http://"+window.location.hostname+(window.location.port
!== '' ? ':'+window.location.port : ''),

should be

elasticsearch: window.location.protocol+"//"+window.location.hostname+(
window.location.port !== '' ? ':'+window.location.port : '')

Cheers,
Jonny

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/c536426a-36a6-4a24-888c-95ff0a4d053f%
40googlegroups.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/897ac725-e037-4f77-9541-ec56a90b00bf%40googlegroups.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQDvY_ETGisEGiOyKNLirn%2Bo8PiD8xhe%2BQij0PQB4Jbz_A%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(J. Schulz) #5

You wrote: "I am assuming that the elasticsearch team has Marvel as a
private repo, which means you can't post issues."

I just wanted to show you that I already searched for a place where to
report "bugs" for Marvel and ask Shay on Twitter.

Is it clear now? Have a nice day :slight_smile:

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/1d3b1c85-4cf9-43fd-bd40-72e728b3ddaa%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Ivan Brusic) #6

Understood. :slight_smile: Can't quite parse twitterspeak early in the morning. It was
interesting seeing a post about Marvel and then immediately someone on the
mailing list asking a question. Wow, that was fast.

For those that missed the news:

On Tue, Jan 28, 2014 at 8:22 AM, J. Schulz js.bloonix@gmail.com wrote:

You wrote: "I am assuming that the elasticsearch team has Marvel as a
private repo, which means you can't post issues."

I just wanted to show you that I already searched for a place where to
report "bugs" for Marvel and ask Shay on Twitter.

Is it clear now? Have a nice day :slight_smile:

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/1d3b1c85-4cf9-43fd-bd40-72e728b3ddaa%40googlegroups.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQCRARt0KPAqu0HkMOiMOEv5hp4pbnf9VXb-pKM2UVJeZw%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Will Appleby) #7

Glad to see this has been reported already. I ran into the exact same
problem and figured out the same fix too. It would be great if Marvel (and
Kibana actually does the same thing I believe) could modify the supplied
config.js to use window.location.protocol instead of assuming "http://" all
the time.

Great product though :slight_smile:

Cheers,
Will.

On Tuesday, January 28, 2014 3:45:04 PM UTC, J. Schulz wrote:

Hi,

I have Nginx configured as reverse proxy to access elasticsearch over
https + auth basic. As example

Unfortunately Marvel tries to connect to http://hostname/.

The affected code line is in
/usr/share/elasticsearch/plugins/marvel/_site/kibana/config.js

elasticsearch: "http://"+window.location.hostname+(window.location.port
!== '' ? ':'+window.location.port : ''),

should be

elasticsearch:
window.location.protocol+"//"+window.location.hostname+(window.location.port
!== '' ? ':'+window.location.port : '')

Cheers,
Jonny

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/f9b3cdb7-db59-468e-9c75-a0b95a52c130%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Sean Gallagher) #8

Thanks for reporting this issue! I've submitted the issue to the internal
repo and the team will take care of it. Keep 'em coming!

On Tuesday, January 28, 2014 10:45:04 AM UTC-5, J. Schulz wrote:

Hi,

I have Nginx configured as reverse proxy to access elasticsearch over
https + auth basic. As example

Unfortunately Marvel tries to connect to http://hostname/.

The affected code line is in
/usr/share/elasticsearch/plugins/marvel/_site/kibana/config.js

elasticsearch: "http://"+window.location.hostname+(window.location.port
!== '' ? ':'+window.location.port : ''),

should be

elasticsearch:
window.location.protocol+"//"+window.location.hostname+(window.location.port
!== '' ? ':'+window.location.port : '')

Cheers,
Jonny

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/c715e943-9b38-465b-a3ef-64ba168032c5%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Boaz Leskes) #9

Hi,

Just wanted to drop a note that we just release Marvel 1.0.2 which contains
a fix for this.
See http://www.elasticsearch.org/guide/en/marvel/current/#_change_list .

Cheers,
Boaz

On Friday, January 31, 2014 3:23:33 PM UTC+1, Sean Gallagher wrote:

Thanks for reporting this issue! I've submitted the issue to the internal
repo and the team will take care of it. Keep 'em coming!

On Tuesday, January 28, 2014 10:45:04 AM UTC-5, J. Schulz wrote:

Hi,

I have Nginx configured as reverse proxy to access elasticsearch over
https + auth basic. As example

Unfortunately Marvel tries to connect to http://hostname/.

The affected code line is in
/usr/share/elasticsearch/plugins/marvel/_site/kibana/config.js

elasticsearch: "http://"+window.location.hostname+(window.location.port
!== '' ? ':'+window.location.port : ''),

should be

elasticsearch:
window.location.protocol+"//"+window.location.hostname+(window.location.port
!== '' ? ':'+window.location.port : '')

Cheers,
Jonny

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/b5ac68c3-b546-406c-95b1-d483e81fea6f%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #10