Metricbeat dashboard + visualization error - Saved "field" parameter is now invalid. Please select a new field


(Vramakrishnan) #1

I have metricbeat setup on my MAC and metrics are uploaded to ES. I have also run the metric beat setup to configure dashboards.

ES: 5.4.1
Kibana: 5.4.1
Metricbeat: 7.0.0-alpha1

metric beat index in created

yellow open metricbeat-7.0.0-alpha1-2017.09.11 9OD-DM8cRxauhVcgcB_0bQ 1 1 4220 0 1.3mb 1.3mb

Dashboard setup

[metricbeat] $ ./metricbeat setup --dashboards
Loaded dashboards

[metricbeat] $ ./metricbeat setup --template
Loaded index template

I am unable to make the Visualization and Dashboard work. I am getting the following errors show on.

I looked at related issues in discuss kibana topics and tried refreshing the index etc but can make it work. Any help is appreciated.


(Christian Dahlqvist) #2

This looks odd. Should this not be Metricbeat 6.0.0-alpha1?


(Vramakrishnan) #3

[metricbeat] $ git log .
commit c2d7b13d45d4c8ee033fabdb8344089a6264ede2
Author: DeDe Morton dede.morton@elastic.co
Date: Mon Sep 11 13:18:08 2017 -0700

[Docs] Add option to log messages in JSON (#4931)

* [Docs] Add option to log messages in JSON

* Add logging.files.permissions to full reference yml file

Edit description of file permissions

[metricbeat] $ ./metricbeat --version
metricbeat version 7.0.0-alpha1 (amd64), libbeat 7.0.0-alpha1


(Christian Dahlqvist) #4

We are currently working on metric beat version 6.0.0, which is currently in beta2, so you should use that instead. You can get it here. If trying out Metricbeat 6.0.0, you should also use the same version of Elasticsearch and Kibana.


(Vramakrishnan) #5

Thanks, it worked with 6.0.0 metric beat.

I need to compile metric beat for ARM and may I know the git tag/SHA to get 6.0.0 metric beat source code.


(Christian Dahlqvist) #6

I have no idea about that, but would recommend you ask in the Beats category.


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.