Migration from 5.2.2 to 6.1.1 - Index data is missing


(raj shah) #1

Hello,

I have an active Elastic Search cluster v5.2.2 that I am currently using.
We are planning to migrate ES to 6.1.1.

While the older version was installed using rpm file, we installed the new version using tar file.
I have copied the data folder from older version to new version (new version will be installed on different machines) without shutting down the old cluster. Data size is around 800GB which took around 1 hour to copy.

All the indices of older cluster have been detected in the new cluster, but the data in those indices is completely missing.

Logs continuously show the following warning:
[[INDEX_NAME]] can not be imported as a dangling index, as index with same name already exists in cluster metadata

Please help why the data is missing in the newer version.

Thanks in advance.


(Bryan Vest) #2

The index data can not be copied like that. The migration process has to be followed. This document should help.
https://www.elastic.co/guide/en/elasticsearch/reference/current/setup-upgrade.html

Before starting upgrade you must read breaking changes here
https://www.elastic.co/guide/en/elasticsearch/reference/current/breaking-changes.html

I would upgrade the current cluster first. After that is complete add the new nodes let the shards level out and start decommissioning the old nodes.


(raj shah) #3

Hi @murlin99,

Thanks for the help.
Actually, I had created a demo index on ES v5.2.2 with a small set of data and copied the data folder on another system with ES v6.1.1.
And it had worked properly without any data loss.

After that approach was successful, I followed the same procedure for a larger set; but it failed.

Can you please explain why the above process won't work.

The reason for trying this approach is that we cannot afford any downtime.

Thanks :slight_smile:


(Bryan Vest) #4

I tested doing it this way with a 1.5TB dataset. Some indices did work, some had problems. It came down to index mapping changes.

If you have a multi node cluster the rolling upgrade should not cause down time. Though make sure to check out the breaking changes, there were mapping changes between 5.x and 6.1.1.


(raj shah) #5

Hi @murlin99,

I have checked the breaking changes and did not find anything relevant to my indices.
The same mapping worked on the smaller set as well.

Any other solution, kindly help...URGENT.

Thanks :slight_smile:


(Bryan Vest) #6

I can not suggest anything other than the upgrade procedure explained in the document. Except for the one test of copying all of the data just to see what would happen I have always used the rolling upgrade.


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.