Missing Data Nodes on Cluster Monitoring of Kibana

A pleasant day everyone!

I have this issue on my Kibana Cluster Monitoring, it happens that my data nodes are missing and only the monitoring nodes is there. I checked the config xpack.monitoring.collection.enabled : true, it is set to true. So i'm wondering why my data nodes is not visible. May I ask for help? Thanks in advance :slight_smile:

On addition onto that, all the data nodes are showing when I used this command GET _cat/nodes?v

@wonderland14 -

  1. Based on my understanding, your environment is as follows:
  • One cluster you wish to monitor.
  • Another cluster receiving the monitoring data.

Is my understanding correct?

  1. It seems that you may be trying to use the legacy collection which has been deprecated in version 7.16. (c.f Collecting monitoring data using legacy collectors). The preferred way of collecting monitoring data would be use to use Metricbeat (c.f Collecting Elasticsearch monitoring data with Metricbeat).

  2. If you wish to keep using the legacy collection, we can take a further look at the existing configuration.

1 Like

Thanks @ropc :slight_smile:

should I share my elasticsearchengine.yml to see further information?

Perhaps you can review my previous updates @wonderland14 and confirm our understanding and the collection method you are using.

1 Like

yes, confirmed that its the collection procedure we followed.

@wonderland14 - are you the legacy collection or the Metricbeat collection? And what about your environment? Was my understanding correct in my first reply (i.e two clusters? one monitored, one monitoring)?

I am still unclear on your setup @wonderland14 but I will assume the following:

  • 1 monitored cluster
  • 1 monitoring cluster
  • Legacy collection

Based on the initial screenshot, it seems that you have enabled the collection of monitoring data for the monitoring cluster only.

If you want to send the monitoring data from the monitored cluster to the monitoring cluster, you need to configure a http exporter (c.f HTTP exporters | Elasticsearch Guide [7.17] | Elastic).

may I know where can I see this HTTP configs? I'm not sure if the previous assigned person enable that settings

It is part of the Elasticsearch configuration in the monitored cluster. They may be set in the elasticsearch.yml file or in the cluster settings (the configuration of http exporter is dynamic).

1 Like

Thanks! It worked, we enable the xpack security to true then restart the server
xpack.security.enabled: true

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.