Missing field in index mapping breaks visualizations


I am encountering a Problem with Canvas on Kibana 6.6.0 that was not present in 6.4.x: When trying to query a field that is not present in the mapping of an index, the whole visualization fails instead of just not showing the data for that field.
E.g. say we want to query two fields: "firstname" and "lastname" and display them in a table.

esdocs index="users" fields="firstname, lastname"
| table
| render

Previously, when "firstname" was present in the index mapping but "lastname" was not, the table would just show a "firstname" column with the corresponding entries and ignore the "lastname" field until it was present in the mapping. But now it throws an error: "Unknown column [lastname]".

Is this something that is planned to be fixed or is this the expected behavior? And if so, is there a way to work around this other than having to define every field that might exist manually in the index mapping?

Thanks in advance,

Seems to me like that should throw an error, so I'm not sure why it worked to begin with.

Have you tried not specifying the fields at all? It will select all of them by default.

Hey, thanks for your answer. Above I used a very simplified example. In reality I am querying over an index alias that contains multiple indices.

Not specifying any fields at all would be an option, but since I query over multiple indices I get the "trying to retrieve too many docvalue_fields.." error and I would like to avoid increasing the index.max_docvalue_fields_search setting for the indices.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.