N00b trying to set up on Windows

Hello- Setting up and trying to learn ELK. I have it all set up and working on a win2016 server from localhost. I also got Kibana to work from laptop using in the kibana.yml file.

For elasticsearch, I have tried to do the same to the same. On the Win2016 server, if I open a browser and go to http://localhost:9200, I get the correct response and it works.

If I go into elasticsearch.yml and add

The elasticsearch service will not launch. What am I doing wrong?

when elasticsearch starts, it is writing a logfile which should contain more information. The location of that file depends how you installed Elasticsearch, see https://www.elastic.co/guide/en/elasticsearch/reference/7.3/windows.html

So you agree that it SHOULD work?

Will review and update. Thanks

Hi @jhmariscal

No actually we are not saying that should work... :slight_smile:

See Here and Here

These are important concepts please take a look and read

You are most likely getting this error

[2019-08-30T09:16:07,451][INFO ][o.e.b.BootstrapChecks    ] [ceres] bound or publishing to a non-loopback address, enforcing bootstrap checks
ERROR: [1] bootstrap checks failed
[1]: the default discovery settings are unsuitable for production use; at least one of [discovery.seed_hosts, discovery.seed_providers, cluster.initial_master_nodes] must be configured
[2019-08-30T09:16:07,460][INFO ][o.e.n.Node               ] [ceres] stopping ...

You can add discovery.type: single-node which you can read about here and that should let you start the node.

These are important checks as this is to make sure people are making conscious decisions about making Elasticsearch network addressable especially if they have not implemented any security... things to think about.

When you attach to anyone that knows the endpoint can now access that instance and the data within it... until you secure it... in addition if this were part of a cluster it would need to know how to discover other nodes etc.

1 Like

Fair enough. Let me check all that. I appreciate the help!

1 Like

Just wanted to let you know that I got it working. Your response helped. Thanks!

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.