when, es can be working normally. However, when i set (real ip like ) "", the error will come up .... does anyone know this issue...please kindly help...

logs here:

[2017-11-25T00:51:47,905][INFO ][o.e.t.TransportService   ] [afs-node-1] publish_address {}, bound_addresses {}
[2017-11-25T00:51:47,923][INFO ][o.e.b.BootstrapChecks    ] [afs-node-1] bound or publishing to a non-loopback or non-link-local address, enforcing bootstrap checks
[2017-11-25T00:51:47,927][ERROR][o.e.b.Bootstrap          ] [afs-node-1] node validation exception
[3] bootstrap checks failed
[1]: max file descriptors [65535] for elasticsearch process is too low, increase to at least [65536]
[2]: max number of threads [1024] for user [useres] is too low, increase to at least [4096]
[3]: max virtual memory areas vm.max_map_count [65536] is too low, increase to at least [262144]
[2017-11-25T00:51:47,930][INFO ][o.e.n.Node               ] [afs-node-1] stopping ...
[2017-11-25T00:51:47,975][INFO ][o.e.n.Node               ] [afs-node-1] stopped
[2017-11-25T00:51:47,975][INFO ][o.e.n.Node               ] [afs-node-1] closing ...
[2017-11-25T00:51:47,988][INFO ][o.e.n.Node               ] [afs-node-1] closed

Please read


after reading the link, I added discovery.type: single-node. It works like a charm...thank u ...but it comes up another issue for me.

Because I would like to use kibana but received a red, so I followed
curl -s http://localhost:9200/.kibana/_recovery?pretty
curl -XPUT 'localhost:9200/.kibana/_settings' -d '
"index" : {
"number_of_replicas" : 0

tried to make red to green in kibana.
Unfortunately, the error is {"error":"Content-Type header [application/x-www-form-urlencoded] is not supported","status":406}

so how can this be solved?

You need to pass a Content-Type to tell elasticsearch that you want to communicate in JSon.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.