New report error:No throughput metrics available for [bulk]. Likely cause: The benchmark ended already during warmup

Hello,I use the new guide to run customize track,but when i run ,the esrally result report

the esrally vesion is 1.3.0


as you can see in the output, it says:

The benchmark ended already during warmup.

That is already the reason you are not seeing any throughput metrics in this report. Warmup samples are intended to warmup the system for the benchmark but are not considered suitable for measuring any useful results and are thus explicitly excluded from this report.

Therefore, you need to increase the size of your data set (or lower the warmup-time-period for this task but that would probably be counter-productive because the system is not yet properly warmed up). See also our blog post Seven Tips for Better Elasticsearch Benchmarks for more benchmarking tips.


I Remove the "warmup-time-period",the error disappear。I don't know that is right operation.
Another question,when i run customer tracks and data,the bulk throught shows the A media is small than B media,but A latency is small than B, so the media bulk througth A show be bigger than B media???

I have already advised against doing this in my earlier answer, please see also the blog post I've linked to. Also, this is not an "error" but rather an indication that something is wrong with your benchmark setup: Your benchmark is finishing too quickly for the system to be properly warmed up and you may draw unrealistic conclusions from the benchmark. I advise that you:

  1. Reread the blog post, specifically the section about system warmup.
  2. Increase the size of your data set so that Elasticsearch is properly warmed up before Rally starts the measurement phase.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.