Newbie, stuck in 1st tutorial

I have ElasticSearch 5.2 and Kibana 5.2 up and running, and I am connected to Kibana via browser (localhost:5601).

I tried to get the "Loading sample data" tutorial to run, but lack some information.

Where am I supposed to place the downloaded and unpacked sample data?

Currently, I am stuck with this command:
POST 'localhost:9200/bank/account/_bulk?pretty' --data-binary @accounts.json
I get the result
No handler found for uri [/%27localhost:9200/bank/account/_bulk?pretty%27%20--data-binary%20@accounts.json] and method [POST]

Any hints?

It looks like maybe you're pasting that into the console under Dev Tools in Kibana? The tutorial is designed to be used with your system command line and the curl utility.

I suspected something like that, but since the tutorial doesn't specify where to enter the commands, the dev tools in Kibana seemed to be the obvious choice

Thanks for commenting on this, I've raised to see if we can clarify the docs.

Try using the browser add on 'sense'. that makes life easy.

Sense = Console, it's now built into Kibana.

Thanks for your comments. Once you know that curl is an external 3rd party tool (and not a builtin command), things make sense and it's easy to look up further information.

The "data mapping" part of the sample doesn't seem to work on my windows command line. Fortunately, that part can easily be done in the Kibana console
Here is the 1st error message I get:

{"error":{"root_cause":[{"type":"security_exception","reason":"missing authentication token for REST request [/shakespeare]","header":{"WWW-Authenticate":"Basic realm="security" charset="UTF-8""}}],"type":"security_exception","reason":"missing authentication token for REST request [/shakespeare]","header":{"WWW-Authenticate":"Basic realm="security"

Also, what's slightly confusing is that this is a Kibana tutorial, but doesn't seem to need Kibana at all - only Elasticsearch.

What's really stopping me now it this strange error:

curl -XPOST 'localhost:9200/shakespeare/_bulk?pretty' --data-binary @shakespeare.json
curl: (6) Couldn't resolve host ''localhost'

I have signed up for elastic cloud (, so if it's not the Kibana console, where do I run these curl bulk commands?

You run then in a shell command somewhere.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.