No cached mapping for this field / refresh of fields not working

Hi,

Any new fields added to my index are ignored by my index pattern. The fields list remain empty.
I tried to refresh field list, to remove / add index pattern, to remove / re-create index...

The fields are shown in the Discover panel.

Any idea ? I tried to add a nested object to my index, and I know Kibana doesn't handle it, maybe it's related ?

Thanks for your help !

The fields are shown in the Discover panel.

Do you see your fields when you add or refresh the index pattern? They should show up in the Management page...

You won't see anything in Discover unless it has documents to show you. Keep the time picker in mind, by default it shows documents from the last 15 minutes, so if your data is older than that, you'll need to adjust the time range to see documents, and then you'll also see fields.

The fields are shown in the Discover panel, with according data when I perform a search. But they are missing when I add or refresh the index pattern.

I found why.
My mapping dynamic option's value of my index was "false". I made a mistake when defining the properties of my type. Thus, according to documentation:

Newly detected fields are ignored. These fields will not be indexed so will not be searchable but will still appear in the _source field of returned hits. These fields will not be added to the mapping, new fields must be added explicitly.

I changed to dynamic: strict, to avoid this behaviour.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.