No Central metricbeat data coming through

I have a metricbeat enrolled and it's status is updating fine.

I am using Elastic Cloud so it's not a license or security issue that I am aware of. I have tried both token and user/name password and both enroll successfully no data comes through. My previous configuration using .yml direct worked fine.

I have no hosts in the host textbox that was giving me errors.

I have a very simple configuration

  • percentages
  • percentages
    enabled: true
    by_cpu: 10
    by_memory: 10

However no data is coming through, there are no errors in any of the logs and I'm stumped.

Any help would be appreciated.

here is the records from the logs.
2019-11-08T08:15:18.107+1000 INFO instance/beat.go:292 Setup Beat: metricbeat; Version: 7.4.2
2019-11-08T08:15:18.108+1000 INFO instance/beat.go:322 Output is configured through Central Management
2019-11-08T08:15:18.108+1000 INFO [publisher] pipeline/module.go:97 Beat name: *************
2019-11-08T08:15:18.108+1000 INFO instance/beat.go:422 metricbeat start running.
2019-11-08T08:15:18.108+1000 WARN [cfgwarn] management/manager.go:126 BETA: Central management is enabled
2019-11-08T08:15:18.108+1000 INFO [centralmgmt] management/manager.go:127 Starting central management service
2019-11-08T08:15:18.108+1000 INFO [centralmgmt.event_reporter] api/event_reporter.go:52 Starting event reporter service
2019-11-08T08:15:18.108+1000 INFO [monitoring] log/log.go:118 Starting metrics logging every 30s
2019-11-08T08:15:18.108+1000 INFO [centralmgmt] management/manager.go:328 Updating state to 'STARTING'
2019-11-08T08:15:19.877+1000 INFO [centralmgmt] management/manager.go:239 New configurations retrieved
2019-11-08T08:15:19.877+1000 INFO [centralmgmt] management/manager.go:328 Updating state to 'IN_PROGRESS'
2019-11-08T08:15:19.877+1000 INFO [centralmgmt] management/manager.go:279 Applying settings for metricbeat.modules
2019-11-08T08:15:19.878+1000 INFO helper/privileges_windows.go:79 Metricbeat process and system info:

2019-11-08T08:17:48.108+1000 INFO [monitoring] log/log.go:145 Non-zero metrics in the last 30s {"monitoring": {"metrics": {"beat":{"cpu":{"system":{"ticks":156,"time":{"ms":16}},"total":{"ticks":374,"time":{"ms":31},"value":374},"user":{"ticks":218,"time":{"ms":15}}},"handles":{"open":416},"info":{"ephemeral_id":"**************","uptime":{"ms":151048}},"memstats":{"gc_next":14457120,"memory_alloc":11381672,"memory_total":25483616,"rss":135168},"runtime":{"goroutines":31}},"libbeat":{"config":{"module":{"running":0}},"pipeline":{"clients":1,"events":{"active":161,"published":33,"total":33}}},"metricbeat":{"system":{"cpu":{"events":1,"success":1},"memory":{"events":1,"success":1},"network":{"events":10,"success":10},"process":{"events":18,"success":18},"process_summary":{"events":1,"success":1},"socket_summary":{"events":1,"success":1},"uptime":{"events":1,"success":1}}}}}}

Hi @gytaco,

Did you configure an output?

Best regards

No I have been unable to do you have a simple config that should work? It's not clear what should go in the config and I dont know whether it's my syntax or something else that I am not doing properly.

Hi are there any updates to this?