No data straming

I am trying to install elastic agent to ship logs and metrics from linux machine to Elastic (fleet server)
Elastic version : 8.5
kibana version : 8.5 
Elastic-agent version : 8.5 

After logging in to kibana and navigating to fleet tab and following the instruction to create the fleet server (VM on my physical machine), also installed the agent in the same machine, and attache the default policy (fleet server policy) to the agent and can collect the logs of the machine, but when I am trying to follow the same steps of installing the agent to my physical machine it can not ship the logs to the fleet server so I tried to run 

mustafa@mustafa-husny:/opt/elastic-agent/elastic-agent-8.5.0-linux-x86_64$ ./elastic-agent diagnostics 
Error: failed to communicate with Elastic Agent daemon: rpc error: code = Unavailable desc = connection error: desc = "transport: Error while dialing dial unix /opt/elastic-agent/elastic-agent-8.5.0-linux-x86_64/data/tmp/elastic-agent-control.sock: connect: no such file or directory"
For help, please see our troubleshooting guide at https://www.elastic.co/guide/en/fleet/8.5/fleet-troubleshooting.html

As you can see the installation directory is ( /opt/elastic-agent/) and it searching for (.sock) file in the (tmp) directory, As I understand it is just to open the connection and when the connection is closed it will be removed (correct me if I am wrong)

I tried to restart it and it gives me the same error 
tried to uninstall then reinstall it again with no luck also 

The approach of the installation is to collect logs, metrics and security endpoint 

Any recommendation for the issue 


The config in the server side 
SeLinux = 0 
firewalld is disabled 

tried to telnet using the ip and port and it is connected