No index found in kibana index pattern after ship a json-format log file to ES


(Kevin.Wu) #1

Hi, guys

I'm a newbee to FileBeat. Recently, I was trying to ship a custom json-format log file to ES. The file looks like this:

{"id":"8cb66f382d418648d0a26f5de7369e315eb06a82","status":"running","configPath":"/mnt/sdb1/storj/storage1","uptime":"9d 5h 40m 22s","restarts":0,"peers":22,"allocs":29,"dataReceivedCount":0,"delta":"39ms","port":4000,"shared":"23.32MB","sharedPercent":"0","bridgeConnectionStatus":"connected"}
{"id":"1295583a1c2367f1eda991ab438519dbea1d4ef1","status":"running","configPath":"/mnt/sdb1/storj/storage3","uptime":"9d 5h 39m 56s","restarts":0,"peers":42,"allocs":33,"dataReceivedCount":0,"delta":"42ms","port":40002,"shared":"...","sharedPercent":"...","bridgeConnectionStatus":"connected"}

And the filebeat.yml :

filebeat.prospectors:
-type: log
enabled: true
paths: - /root/data.json
json.keys_under_root: true
json.overwrite_keys: true
json.add_error_key: true
json.message_key: log
output.elasticsearch:
hosts: ["192.168.8.232:9200"]
#Optional protocol and basic auth credentials.
#protocol: "https"
username: "elastic"
password: "LzxOPeLupVovJSmJTXkq"

I saw that the log file can be sended to ES. and I want to use kibana to show the json data, but except the default index filebeat*, There is no index associated with the log file I want. What can I do now? Any suggestions , Thank you .


(Carlos Pérez Aradros) #2

Hi @Kevin.Wu,

Filebeat sends logs to filebeat-* indices by default, if everything is working correctly your logs should appear there. Did you check in under that index pattern?

Best regards


(Kevin.Wu) #3

Thanks for reply @exekias , Yes, I found the messages I need among all of these

I just missed it. Now everything is working well , Thanks.


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.