No Kibana plugins working when login over https


(Craig Foote) #1

We just installed Kibana 4.5.0 with the license, sense, marvel and graph plugins. All plugins worked until we turned on browser-Kibana access over https (following https://www.elastic.co/guide/en/shield/current/kibana.html step 5). We set the 2 kibana.yml properties:

server.ssl.key: /path/to/your/server.key
server.ssl.cert: /path/to/your/server.crt

.. and restarted Kibana. We now access the server using https fine and when we click the "plugins" icon at the top we see the 4 plugins listed but clicking either of them causes the page to spin without return, i.e. the plugin page never renders. The kibana.log shows the request but no error. What could be the problem?

Craig


(Shaunak Kashyap) #2

Hi Craig,

I just tried to replicate this on my end but couldn't :frowning: Would you mind pasting a couple of things here?

  1. The output of ./bin/kibana plugin --list, when run from your Kibana installation folder,
  2. The output of ./bin/plugin list, when run from your Elasticsearch installation folder, and
  3. Any output in the Developer Tools console of your browser (assuming Chrome or Safari) after you click on any of the plugin icons in Kibana.

Thanks!


(Craig Foote) #3

From ./bin/kibana plugin --list I get:

graph
marvel
sense
fs.js:549
return binding.open(pathModule._makeLong(path, stringToFlags(flags), mode);
^

Error: EACCES: permission denied, open '/licensed/elk/kibana-4.5.0-linux-x64/optimize/.babelcache.json'
at Error (native)
at Object.fs.openSync (fs.js:549:18)
etc.

From ./bin/plugin list in Elasticsearch folder I get:

Installed plugins in /licensed/elk/elasticsearch/plugins:

  • license
  • kopf
  • shield
  • hq

(Craig Foote) #4

Please ignore that error from kibana plugin --list. I forgot to sudo to my app owner before invoking it. When I did I simply got:

graph
marvel
sense

Craig


(Craig Foote) #5

In FF's developer tools window, I see this error when I invoke graph:

TypeError: modules[moduleId] is undefined commons.bundle.js line 51


(Shaunak Kashyap) #6

I'm not sure if this is the cause of the issue but its something you should fix anyway: In addition to installing the graph and marvel plugins in Kibana, you also need to install them in Elasticsearch.

To install these plugins in Elasticsearch, run these commands in your Elasticsearch install directory:

./bin/plugin install graph
./bin/plugin install marvel-agent

If that doesn't fix the issue, we can investigate further.


(Craig Foote) #7

Ok, long story short, we applied the graph plugin to elasticsearch on two of our clusters. On one, we still cannot see the graph link in kibana and the "kibana plugin --list" shows an error to the effect that the graph APIs are disabled, not sure why. On the other cluster, no change, we see the graph link in kibana but clicking it sends the web page spinning and it never returns. Our sysadmin guy says he doesn't want to apply the marvel-agent on either one of the clusters yet. Any other ideas?

Craig


(system) #8