"No monitoring data found" error on Kibana

monitoring

(Jason Y) #1

hello,

my Kibana worked without issues for a while but started displaying "No monitoring data found" error today, then Status turned to RED on Kibana. I executed _cluster/health command on the servers, but all status were GREEN. I checked via _cat API but all .monitoring* indices are existed.

why is this happened? why kibana suddenly not able to find .monitoring* indices? why Status'es are different btw kibana and actual servers?

Please advice.

thanks!


(Kanagat) #2

yesterday observed this behavior, somebody help plz)


(Kanagat) #3

@af615dbd55cac2cacf32, today i noticed that problem solved by itself when check monitoring plugin in kibana.


(Jason Y) #4

Hello,

Did you restarted your Elasticsearch then it was resolved?

I tracked myself with all nodes log files. It looked my warm nodes used all heap memory which i set. L related logs i found were shown as below link.

I guess .monitoring indices were not able to be updated from warm nodes after that happened, then my kibana was ahown above error. Weird thing was kibana displayed Status:RED after that even though _cluster/health execution result via each actual nodes were still Status:green.

I decided to restart warm nodes, then issue was gone.

Thank you for sharing update btw.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.