No X-pack settings in Kibana.yml even when the plugin is installed


(Mulligan) #1

I dont see any X-pack related setting in Kibana.yml file although the X-pack plugin is installed, neither do i see anything on the Kibana UI .

/usr/share/kibana/bin/kibana-plugin list
metric_percent_vis@5.5.1
x-pack@5.5.1


(Samuel Larsen Disney) #2

you can find the xpack settings in the elasticsearch.yml


(Mulligan) #3

I am sure i can find in elasticsearch.yml but i need the x-pack for kibana where i want to see various modules like Monitoring, Machine learning etc


(Tim Sullivan) #4

Installing X-Pack doesn't change the config file automatically. At first after install, X-Pack will run with all the config defaults.

If you want to find the configurable options for X-Pack, you have to look up the documentation: https://www.elastic.co/guide/en/x-pack/current/xpack-settings.html


(Mulligan) #5

I agree, but once i install X-pack shouldnt i see the modules like Monitoring, Machine Learning etc on the Kibana UI

But mine doesnt show anything


(Tim Sullivan) #6

Maybe X-Pack didn't get installed in Kibana as well?

Did you run bin/kibana-plugin install x-pack in the Kibana install path?


(Mulligan) #7

Yes i installed using the x-pack which i downloaded manually. my server doesnt have internet access

./kibana-plugin install file:///home/uns114/x-pack-5.5.1.zip


(Tim Sullivan) #8

Cool - that should work for installing X-Pack.

Have you restarted Kibana after doing the X-Pack install?


(Mulligan) #9

Yes i did systemctl restart kibana

and when i do ./kibana-plugin list

it gives me the output showing x-pack is installed


(Mulligan) #10

x-pack@5.5.1


(Tim Sullivan) #11

Hm, well I think I can safely assume you didn't disable the plugins in kibana.yml, because of your earlier questions.

Try closing all your browser windows, and re-opening the Kibana UI. If that doesn't work, try clearing your cookies and your browser cache.


(Mulligan) #12

Yes i did clear the cache, closed all the tabs and restarted the browser. It doesnt help. The problem is that i dont see any settings in kibana.yml file related to x-pack settings. That is kind of strange.


(Mulligan) #13

Could it be a permission issue? My x-pack directory under /usr/share/kibana/plugin is owned by root and kibana is running as "kibana" user.


(Tim Sullivan) #14

Installing X-Pack in Kibana doesn't touch or make any changes to the kibana.yml file.

There are documented steps for ensuring that the Kibana user can access the plugin that was installed. See: https://www.elastic.co/guide/en/kibana/master/_installing_plugins.html#_installing_plugins_with_linux_packages - hopefully that's the only issue :grinning:


(Mulligan) #15

I again installed it but now get this error while i launch the console:


(Tim Sullivan) #16

Looks like the installation of the X-Pack plugin in Kibana wasn't successful. Can you please try the steps given in this issue: https://github.com/elastic/kibana/issues/9369#issuecomment-264896049


(Mulligan) #17

if i delete the files and folders, do i lose any visualisations that i have on kibana currently. I dont want to lose any of that work.


(Tim Sullivan) #18

No, the visualizations and work you do in Kibana is stored in Elasticsearch in the .kibana index.


(Mulligan) #19

it started working now, but the question is , how do i get x-pack working? that was the real challenge :slight_smile:


(Mulligan) #20

Thanks, after multiple attempts it is working now :slight_smile: