Not able to install the elastic search report plugin

Hi All,

We are trying to install the elastic search report plugin which one is available on git hub malike/elasticsearch-report-engine

But getting the error ERROR: elasticsearch directory is missing in the plugin zip

We are trying to install using the below command

bin/elasticsearch-plugin install

Any help should be appreciated.

Not sure of what you downloaded. Probably the github source and not the distribution itself.
As far as I can read the Github README it seems to be available only with elasticsearch 5.4.1:

Thanks. understand the issue need to download the distribution..


we have tried in Elastic search 5.4.1 facing Exception in thread "main" SSL peer shut down incorrectly.

What does mean that? Could you please explain this issue?

What is the full message please? The stacktrace.

Please find below the stack trace.

Exception in thread "main" SSL peer shut down incorrectly at at at at at at at at at at$ at at at at java.nio.file.Files.copy( at java.nio.file.Files.copy( at org.elasticsearch.plugins.InstallPluginCommand.downloadZip( at at org.elasticsearch.plugins.InstallPluginCommand.execute( at org.elasticsearch.plugins.InstallPluginCommand.execute( at org.elasticsearch.cli.EnvironmentAwareCommand.execute( at org.elasticsearch.cli.Command.mainWithoutErrorHandling( at org.elasticsearch.cli.MultiCommand.execute( at org.elasticsearch.cli.Command.mainWithoutErrorHandling( at org.elasticsearch.cli.Command.main( at org.elasticsearch.plugins.PluginCli.main( Suppressed: Connection has been shutdown: SSL peer shut down incorrectly at at at at at at at$HttpInputStream.close( at at org.elasticsearch.plugins.InstallPluginCommand.downloadZip( ... 9 more [CIRCULAR SSL peer shut down incorrectly]

What exact command did you run?

.\bin\elasticsearch-plugin install

This is the exact command I run.

I think the link in doc is https not http:

Anyway, can you download it locally then install with:

bin/elasticsearch-plugin install file:///path/to/zip


We have tried https, but unfortunately we have faced the I have shared the screen shot for your reference.


What about the local download I mentioned?

If it's still failing, I'd recommend that you open an issue in the project repository.

we will try the local download and let you know the updates. Thanks a lot for your help.

We have download locally and tried to install, But we are facing difference issue. PFA for reference.

Please don't post images of text as they are hardly readable and not searchable.

Instead paste the text and format it with </> icon. Check the preview window.

Anyway. You need to contact the author.

Thanks and sorry for the inconvenience caused.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.