Not able to search the data in index


(Kartikeya Sharma) #1

Hi ,

I am fetching the data from database through logstash jdbc plugin and ingesting it into elastic search .

When i am querying the data through Kibana or REST from elastic search , i am getting the error as follows

Discover: Fielddata is disabled on text fields by default. Set fielddata=true on [type] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead.

I tried by setting the fielddata=true for the field "type" in the index . But i am not able to figure out the issue .
Any lead on this issue .

Thanks


(Medcl) #2

Hi, @kartikeya_sharma_13 ,
You should customize your mapping before actually ingest the data, if this field you don't need to analyze it, you may set the type to keyword

Medcl


(Medcl) #3

also remember to refresh the index pattern, if you already updated the mapping to enable fielddata, :slight_smile:


(Kartikeya Sharma) #4

Thanks for the input . I refreshed the index pattern in Kibana . Now its working . And yes it being mapped to type keyword.
Thank for the help @medcl.net


(Medcl) #5

you are welcome!