Not specifying Id and replication characteristics


(Ashwin Sathya) #1

Hi,

I have setup a simple 3-node cluster with just 1 shard and 2 replica per index. And I am not specifying the id, during indexing.
Indexing seems to create three different copies of the same item with a different _id on each of the replicas. I am not sure what is happening.

Is this the default behavior ? How does this affect search queries ? Will I be getting duplicating results when I query ?
Should I start specifying the id myself ?

Thanks,
Ashwin Sathya

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #2

I'm not sure I understood:

You ran only one index call and you have 3 documents with different IDs, I mean elasticsearch _id ?
If so, could you gist a curl recreation of what you did so far?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 12 sept. 2013 à 22:40, R Ashwin Sathya ashwin.sathya@outlook.com a écrit :

Hi,

I have setup a simple 3-node cluster with just 1 shard and 2 replica per index. And I am not specifying the id, during indexing.
Indexing seems to create three different copies of the same item with a different _id on each of the replicas. I am not sure what is happening.

Is this the default behavior ? How does this affect search queries ? Will I be getting duplicating results when I query ?
Should I start specifying the id myself ?

Thanks,
Ashwin Sathya

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Ashwin Sathya) #3

Unfortunately I won't be able to right now.
When I don't specify a _id, during a PUT call, _id is automatically assigned by elastic search. Now how does the replication treat this document ? Its just creates a copy or indexes as a separate document ?


From: David Pilatomailto:david@pilato.fr
Sent: 13-09-2013 02:14
To: elasticsearch@googlegroups.commailto:elasticsearch@googlegroups.com
Subject: Re: Not specifying Id and replication characteristics

I'm not sure I understood:

You ran only one index call and you have 3 documents with different IDs, I mean elasticsearch _id ?
If so, could you gist a curl recreation of what you did so far?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 12 sept. 2013 à 22:40, R Ashwin Sathya ashwin.sathya@outlook.com a écrit :

Hi,

I have setup a simple 3-node cluster with just 1 shard and 2 replica per index. And I am not specifying the id, during indexing.
Indexing seems to create three different copies of the same item with a different _id on each of the replicas. I am not sure what is happening.

Is this the default behavior ? How does this affect search queries ? Will I be getting duplicating results when I query ?
Should I start specifying the id myself ?

Thanks,
Ashwin Sathya

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #4

It creates somehow copies. I mean that you won't see duplicates as when you search only one shard is hit (primary or replica)

Makes sense?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 12 sept. 2013 à 23:02, R Ashwin Sathya ashwin.sathya@outlook.com a écrit :

Unfortunately I won't be able to right now.
When I don't specify a _id, during a PUT call, _id is automatically assigned by elastic search. Now how does the replication treat this document ? Its just creates a copy or indexes as a separate document ?
From: David Pilato
Sent: 13-09-2013 02:14
To: elasticsearch@googlegroups.com
Subject: Re: Not specifying Id and replication characteristics

I'm not sure I understood:

You ran only one index call and you have 3 documents with different IDs, I mean elasticsearch _id ?
If so, could you gist a curl recreation of what you did so far?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 12 sept. 2013 à 22:40, R Ashwin Sathya ashwin.sathya@outlook.com a écrit :

Hi,

I have setup a simple 3-node cluster with just 1 shard and 2 replica per index. And I am not specifying the id, during indexing.
Indexing seems to create three different copies of the same item with a different _id on each of the replicas. I am not sure what is happening.

Is this the default behavior ? How does this affect search queries ? Will I be getting duplicating results when I query ?
Should I start specifying the id myself ?

Thanks,
Ashwin Sathya

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Ashwin Sathya) #5

Okay.
Now makes sense.
Thanks!!


From: David Pilatomailto:david@pilato.fr
Sent: 13-09-2013 02:39
To: elasticsearch@googlegroups.commailto:elasticsearch@googlegroups.com
Subject: Re: Not specifying Id and replication characteristics

It creates somehow copies. I mean that you won't see duplicates as when you search only one shard is hit (primary or replica)

Makes sense?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 12 sept. 2013 à 23:02, R Ashwin Sathya ashwin.sathya@outlook.com a écrit :

Unfortunately I won't be able to right now.
When I don't specify a _id, during a PUT call, _id is automatically assigned by elastic search. Now how does the replication treat this document ? Its just creates a copy or indexes as a separate document ?
From: David Pilato
Sent: 13-09-2013 02:14
To: elasticsearch@googlegroups.com
Subject: Re: Not specifying Id and replication characteristics

I'm not sure I understood:

You ran only one index call and you have 3 documents with different IDs, I mean elasticsearch _id ?
If so, could you gist a curl recreation of what you did so far?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Le 12 sept. 2013 à 22:40, R Ashwin Sathya ashwin.sathya@outlook.com a écrit :

Hi,

I have setup a simple 3-node cluster with just 1 shard and 2 replica per index. And I am not specifying the id, during indexing.
Indexing seems to create three different copies of the same item with a different _id on each of the replicas. I am not sure what is happening.

Is this the default behavior ? How does this affect search queries ? Will I be getting duplicating results when I query ?
Should I start specifying the id myself ?

Thanks,
Ashwin Sathya

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #6