Nothing under Security will load all of a sudden

All of a sudden nothing will load under the Security section of our Elastic instance. Everything else works fine. If I try to use anything under Security I just get the elastic logo. I have no idea where to begin troubleshooting. Any suggestions?

Hi @plaroche0,

Could you please share which Kibana version you run and some screenshots of the problem?

Thanks,
Christos

Version is 7.13.2

When I try any of the options under Security. I get this screen with the elastic logo "pulsing" for a few minutes than just a black screen. All options under Analytics works fine though.

chrome_9ia0cgdFAA

Thank you for the information. Could you verify that nothing has changed regarding user permission? Also, could you please open the developer tools, go to the Network tab and see if any of the requests fails?

Thanks,
Christos

User permissions have not changed. The bsearch request is failing.

I have tried searching for what bsearch does or how to troubleshoot it not loading but not having any luck. Any suggestions what to look at?

Hey i am also facing kind of same issue.

Though i have not checked bsearch error but iafter restarting kibana service it is working.

Here is the link for issue i am facing:

So I have seen the same issue. Long story short I just rebooted the kibana processes on each of the servers and everything came back up. If you care the following is what else I have done as we have been dealing with this for a little while now.

I think it is something to do with the task manager. When I look at the Kibana status page a ton of the plugins are listed as red. This is frustrating as there is nothing in the documentation that helps with troubleshooting these plug-in issues (I have looked pretty hard, but haven't found anything at the least). We have been told that we don't have enough resources dedicated to Kibana as well. This is because there is a lot more stuff is apparently happening on kibana then in the past.

If you want to see what is going on throw the following in your browser: https://your kibana address/api/task_manager/_health

Sorry I don't have anything more solid than that, but this has been a problem that we have been facing for a while. It sounds like your Kibana could be under too much stress depending on how many SIEM rules you have enabled and how many dashboards and visualizations your users have up at any one time.

So... good luck