Notify slack action configuration not loading under ES 6.6 with new secure_url setting


Since updating to Elasticsearch 6.6 I am unable to make use of the slack action. I've reviewed the breaking changes and found that the 'url' setting has been deprecated in favor of the new 'secure_url' setting that must be stored in the elasticsearch-keystore. The resultant message of a test execution is that no slack accounts are configured.

I've loaded my Slack webhook url into the specified setting referenced in the documentation using the syntax as follows:

bin/elasticsearch-keystore add xpack.notification.slack.account.monitoring.secure_url

At minimum you were historically only required to include the url for slack actions to function. With this new method of storage in the keystore there is nothing at all configured via the yml in my environment for slack actions.

The results of a configuration check filtered to xpack.notifcations returns no trace of any slack settings on any nodes.

GET _nodes?filter_path=**.settings.xpack.notification

My uneducated guess is that with nothing configured in the elasticsearch.yml, elastic does not 'load' my secure_url setting. Am I missing an xpack.notification.slack: true type flag of some sort?

1 Like

I added a default setting to elasticsearch.yml and it picked up the secure_url setting. Looks like you need something in the yml in order for elasticsearch to load any settings stored in the keystore.

                title: "Test Alert"
1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.