o.e.b.Bootstrap ] [sFoGO6h] node validation exception [1] bootstrap checks failed


(Sankar) #1

Hi all,

I am facing node validation error while starting elasticseach. Here is my debug log, I was not able find if i am missing any configuration. I've configured limit.conf and jvm with proper values

[2017-08-10T09:10:02,951][DEBUG][o.e.d.z.ElectMasterService] [sFoGO6h] using minimum_master_nodes [-1]
[2017-08-10T09:10:02,951][DEBUG][o.e.d.z.ZenDiscovery ] [sFoGO6h] using ping_timeout [3s], join.timeout [1m], master_election.ignore_non_master [false]
[2017-08-10T09:10:02,967][DEBUG][o.e.d.z.MasterFaultDetection] [sFoGO6h] [master] uses ping_interval [1s], ping_timeout [30s], ping_retries [3]
[2017-08-10T09:10:02,970][DEBUG][o.e.d.z.NodesFaultDetection] [sFoGO6h] [node ] uses ping_interval [1s], ping_timeout [30s], ping_retries [3]
[2017-08-10T09:10:03,178][DEBUG][o.e.i.r.RecoverySettings ] [sFoGO6h] using max_bytes_per_sec[40mb]
[2017-08-10T09:10:03,371][DEBUG][o.e.g.GatewayAllocator$InternalPrimaryShardAllocator] [sFoGO6h] using initial_shards [quorum]
[2017-08-10T09:10:03,529][DEBUG][o.e.c.u.IndexFolderUpgrader] [/var/lib/elasticsearch/log-collector/nodes/0/indices/qsaYu46TSHWEd6I99r0xlg] no upgrade needed - already upgraded
[2017-08-10T09:10:03,542][DEBUG][o.e.g.GatewayMetaState ] [sFoGO6h] took 3ms to load state
[2017-08-10T09:10:03,547][DEBUG][o.e.n.Node ] initializing HTTP handlers ...

[2017-08-10T09:10:03,547][DEBUG][o.e.n.Node ] initializing HTTP handlers ...
[2017-08-10T09:10:03,664][INFO ][o.e.n.Node ] initialized
[2017-08-10T09:10:03,664][INFO ][o.e.n.Node ] [sFoGO6h] starting ...
[2017-08-10T09:10:03,680][DEBUG][i.n.c.MultithreadEventLoopGroup] -Dio.netty.eventLoopThreads: 8
[2017-08-10T09:10:03,701][DEBUG][i.n.u.i.PlatformDependent0] -Dio.netty.noUnsafe: true
[2017-08-10T09:10:03,701][DEBUG][i.n.u.i.PlatformDependent0] sun.misc.Unsafe: unavailable (io.netty.noUnsafe)
[2017-08-10T09:10:03,701][DEBUG][i.n.u.i.PlatformDependent0] java.nio.DirectByteBuffer.(long, int): unavailable
[2017-08-10T09:10:03,702][DEBUG][i.n.u.i.PlatformDependent] Java version: 8
[2017-08-10T09:10:03,703][DEBUG][i.n.u.i.PlatformDependent] maxDirectMemory: 7481327616 bytes (maybe)
[2017-08-10T09:10:03,703][DEBUG][i.n.u.i.PlatformDependent] -Dio.netty.tmpdir: /data/tmp (java.io.tmpdir)
[2017-08-10T09:10:03,703][DEBUG][i.n.u.i.PlatformDependent] -Dio.netty.bitMode: 64 (sun.arch.data.model)
[2017-08-10T09:10:03,704][DEBUG][i.n.u.i.PlatformDependent] -Dio.netty.noPreferDirect: true
[2017-08-10T09:10:03,704][DEBUG][i.n.u.i.PlatformDependent] -Dio.netty.maxDirectMemory: -1 bytes
[2017-08-10T09:10:03,704][DEBUG][i.n.u.i.PlatformDependent] -Dio.netty.uninitializedArrayAllocationThreshold: -1
[2017-08-10T09:10:03,723][DEBUG][i.n.c.n.NioEventLoop ] -Dio.netty.noKeySetOptimization: true
[2017-08-10T09:10:03,723][DEBUG][i.n.c.n.NioEventLoop ] -Dio.netty.selectorAutoRebuildThreshold: 512
[2017-08-10T09:10:03,724][DEBUG][i.n.u.i.PlatformDependent] org.jctools-core.MpscChunkedArrayQueue: unavailable
[2017-08-10T09:10:03,738][DEBUG][o.e.t.n.Netty4Transport ] [sFoGO6h] using profile[default], worker_count[8], port[9300-9400], bind_host[null], publish_host[null], compress[false], connect_timeout[30s], connections_per_node[2/3/6/1/1], receive_predictor[64kb->64kb]
[2017-08-10T09:10:03,743][DEBUG][o.e.t.n.Netty4Transport ] [sFoGO6h] binding server bootstrap to: [0.0.0.0]
[2017-08-10T09:10:03,758][DEBUG][i.n.c.DefaultChannelId ] -Dio.netty.processId: 2076 (auto-detected)
[2017-08-10T09:10:03,760][DEBUG][i.n.u.NetUtil ] -Djava.net.preferIPv4Stack: false
[2017-08-10T09:10:03,760][DEBUG][i.n.u.NetUtil ] -Djava.net.preferIPv6Addresses: false
[2017-08-10T09:10:03,762][DEBUG][i.n.u.NetUtil ] Loopback interface: lo (lo, 0:0:0:0:0:0:0:1%lo)
[2017-08-10T09:10:03,764][DEBUG][i.n.u.NetUtil ] /proc/sys/net/core/somaxconn: 128
[2017-08-10T09:10:03,765][DEBUG][i.n.c.DefaultChannelId ] -Dio.netty.machineId: 00:0c:29:ff:fe:6a:b3:e0 (auto-detected)
[2017-08-10T09:10:03,780][DEBUG][i.n.u.ResourceLeakDetector] -Dio.netty.leakDetection.level: simple
[2017-08-10T09:10:03,780][DEBUG][i.n.u.ResourceLeakDetector] -Dio.netty.leakDetection.maxRecords: 4
[2017-08-10T09:10:03,821][DEBUG][i.n.b.PooledByteBufAllocator] -Dio.netty.allocator.numHeapArenas: 8
[2017-08-10T09:10:03,821][DEBUG][i.n.b.PooledByteBufAllocator] -Dio.netty.allocator.numDirectArenas: 8
[2017-08-10T09:10:03,823][DEBUG][i.n.b.PooledByteBufAllocator] -Dio.netty.allocator.pageSize: 8192
[2017-08-10T09:10:03,823][DEBUG][i.n.b.PooledByteBufAllocator] -Dio.netty.allocator.maxOrder: 11
[2017-08-10T09:10:03,824][DEBUG][i.n.b.PooledByteBufAllocator] -Dio.netty.allocator.chunkSize: 16777216
[2017-08-10T09:10:03,824][DEBUG][i.n.b.PooledByteBufAllocator] -Dio.netty.allocator.tinyCacheSize: 512
[2017-08-10T09:10:03,824][DEBUG][i.n.b.PooledByteBufAllocator] -Dio.netty.allocator.smallCacheSize: 256
[2017-08-10T09:10:03,824][DEBUG][i.n.b.PooledByteBufAllocator] -Dio.netty.allocator.normalCacheSize: 64
[2017-08-10T09:10:03,824][DEBUG][i.n.b.PooledByteBufAllocator] -Dio.netty.allocator.maxCachedBufferCapacity: 32768
[2017-08-10T09:10:03,824][DEBUG][i.n.b.PooledByteBufAllocator] -Dio.netty.allocator.cacheTrimInterval: 8192
[2017-08-10T09:10:03,824][DEBUG][i.n.b.PooledByteBufAllocator] -Dio.netty.allocator.useCacheForAllThreads: true
[2017-08-10T09:10:03,835][DEBUG][i.n.b.ByteBufUtil ] -Dio.netty.allocator.type: pooled
[2017-08-10T09:10:03,835][DEBUG][i.n.b.ByteBufUtil ] -Dio.netty.threadLocalDirectBufferSize: 65536
[2017-08-10T09:10:03,835][DEBUG][i.n.b.ByteBufUtil ] -Dio.netty.maxThreadLocalCharBufferSize: 16384
[2017-08-10T09:10:03,850][DEBUG][o.e.t.n.Netty4Transport ] [sFoGO6h] Bound profile [default] to address {[::]:9300}
[2017-08-10T09:10:03,854][INFO ][o.e.t.TransportService ] [sFoGO6h] publish_address {10.207.99.131:9300}, bound_addresses {[::]:9300}
[2017-08-10T09:10:03,866][INFO ][o.e.b.BootstrapChecks ] [sFoGO6h] bound or publishing to a non-loopback or non-link-local address, enforcing bootstrap checks
[2017-08-10T09:10:03,868][ERROR][o.e.b.Bootstrap ] [sFoGO6h] node validation exception
[1] bootstrap checks failed
[1]: system call filters failed to install; check the logs and fix your configuration or disable system call filters at your own risk
[2017-08-10T09:10:03,870][INFO ][o.e.n.Node ] [sFoGO6h] stopping ...

Please do needful to resolve findout the issue

Thanks
Sankar


(Shane Connelly) #2

The error you're seeing:

Is from the system call filter bootstrap check. You can disable that at your own risk, but if possible, look into why they're failing and fix them (e.g. make sure your kernel has CONFIG_SECCOMP and CONFIG_SECCOMP_FILTER compiled in).


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.