Offline plugin install logstash-filter-date_formatter on logstash 7.4.2

I downloaded the zip file with the plugin from Github: https://github.com/wiibaa/logstash-filter-date_formatter

I followed the documentation here, and tried installing the plugin by running the command:

./logstash-plugin install /tmp/logstash-filter-date_formatter-master.zip

However I get a 403 error. I don't understand why this is happening. I assumed that after downloading the zip file from Github, internet access was no longer requiered.

ERROR: Something went wrong when installing /tmp/logstash-filter-date_formatter-master.zip, message: 403 "Forbidden"

Any ideas how to get around this problem?
Thanks in advance

I realized that my command was incomplete. It should be:

./logstash-plugin install file:///tmp/logstash-filter-date_formatter-master.zip

However, now I get the following error:

ERROR: Invalid pack for: file:///tmp/logstash-filter-date_formatter-master.zip, reason; The pack must contains at least one plugin, message: The pack must contains at least one plugin.

I have also tried installing the corresponding gem file, but then I get the error:

ERROR: Invalid pack for: file:///tmp/logstash-filter-date_formatter-2.0.0.gem, reason; Ivalid format, the pack must be in zip format, message: Invalid format, the pack must be in zip format

It seems that the solution involves a different zip file. According to the documentation, I must generate it using the (partial) command:

bin/logstash-plugin prepare-offline-pack

However, I'm not sure what should be complete command.

In case this might be helpfull for someone else, here's how I managed to install the plugin offline:

  1. To follow the documentation, I first had to create a stagging machine with access to the internet.

1.1 With Hyper-V on my Windows machine, I created a virtual CentOS7 machine with access to the internet, installed Logstash in it and installed the plugin using the command:

./logstash-plugin install logstash-filter-date_formatter
  1. From then on, I could start following the documentation.

2.1 The correct zip file was created with the command:

./logstash-plugin prepare-offline-pack logstash-filter-date_formatter

2.2 I moved this file to my offline machine and installed it with the command:

./logstash-plugin install file:///tmp/logstash-offline_plugins-7.4.2.zip