Issue installing Translate Plugin


(Sreejith) #1

We are using logstash 5.2 ..We are trying to install translate plugin and getting below error ..Can anyone advice

[root@x01gnwatlgs1a support]# /usr/share/logstash/bin/logstash-plugin install file:////home/support/logstash-filter-translate-3.0.1.zip
Installing file: //home/support/logstash-filter-translate-3.0.1.zip
ERROR: Invalid pack for: file:////home/support/logstash-filter-translate-3.0.1.zip, reason: The pack must contains at least one plugin, message: The pack must contains at least one plugin

Downloaded the plugin from below


(Magnus Bäck) #2

You can't download a zip file directly from GitHub. See https://www.elastic.co/guide/en/logstash/current/offline-plugins.html for more information on how to install plugins on a system that's not connected directly to the internet. If the machine in question is internet-connected you can of course just use the logstash-plugin command.


(Sreejith) #3

I am following the same procedure .. Downloaded from Github as my VM does not have internet access (Offline installation)..

Error is bit strange

ERROR: Invalid pack for: file:///home/support/logstash-filter-translate-3.0.1.zip, reason: The pack must contains at least one plugin, message: The pack must contains at least one plugin


(Magnus Bäck) #4

Did you read the page I linked to? It does not recommend downloading archives from GitHub.


(Sreejith) #5

ANy other option that you can advice please..I have no way to have internet connection due to compliance ..


(Magnus Bäck) #6

The page I linked to explains how to install plugins on machines without an internet connection. Over and out.


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.