Unable to install the logstash-filter-truncate


(Aleksey Yasinskiy) #1

Hello all

when I try to install the filter I get the message:
bin/logstash-plugin install --no-verify file:///tmp/logstash-filter-truncate-master.zip
Installing file: /tmp/logstash-filter-truncate-master.zip
ERROR: Invalid pack for: file:///tmp/logstash-filter-truncate-master.zip, reason: The pack must contains at least one plugin, message: The pack must contains at least one plugin

LS 5.3


(Jimmy Kuang) #2

Can you attach the logstash-filter-truncate-master.zip file?


(Aleksey Yasinskiy) #3

hello,
https://1drv.ms/u/s!AnNbikBZyEEwjZotlBq4Kj2MZk7OSA


(Mark Walkom) #4

How did you download it?


(Aleksey Yasinskiy) #5

Hello,

I downloaded it as "Download ZIP" from this url https://github.com/logstash-plugins/logstash-filter-truncate


(Jimmy Kuang) #6

Please use the zip file below:


(Aleksey Yasinskiy) #7

It is a magic!!!
# /usr/share/logstash/bin/logstash-plugin install file:///tmp/logstash-filter-truncate-master2.zip
Installing file: /tmp/logstash-filter-truncate-master2.zip
_Install successful

Thanks a lot!


(Jimmy Kuang) #8

No problem, you're welcome.


(Mark Walkom) #9

What was the problem?


(Jimmy Kuang) #10

I believe the github zip required the gem to be build. I just created an offline plug-in zip.


(system) #11

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.