OneDrive connector set up natively, but no ability to edit advanced sync settings

I've wanted to test elastic connectors to check the viability of their use with my organisation.

I sent up an azure ad service, gave it Microsoft Graph API permissions, then pointed to it in the configurations of the native onedrive connector on Elasticsearch.

I was at first under the impression that I needed to use Enterprise Search for those connectors to work, so I created a trial cloud deployment and set it up through there.

Under my deployment details, I can see Enterprise Search listed as an application. Though my Kibana UI only lists it as "Search", the url path says enterprise_search, but the issue is that if I access my indices and select the onedrive connector I successfully created, I have no tab that allows me to access sync rules as shown in Connector sync rules | Enterprise Search documentation [8.11] | Elastic (it has all the tabs except for sync rules and none of the other tabs shows me a way to edit sync rules)

I'm trying to add custom rules to force the connector to only pull files from a certain folder on onedrive.

Hi @AlAnsari ,

Sorry you're running into this. I expect you're hitting this issue, which will be solved in 8.12.0, which should be released very soon.

As a workaround, you can manually enable the "features" for sync rules by finding the connector ID from your configuration tab, and then with cURL or Dev Tools executing:

POST .elastic-connectors/_update/<id>
  "doc": {
    "features": {
      "sync_rules": {
        "advanced": {
          "enabled": true
        "basic": {
          "enabled": true

Hope this helps!

That worked swimmingly, thank you!

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.