Package for Kibana 4.2.0

Hi there!

I've been using this tutorial as how to setup my ELK setup but I wanted to try out the 2.0 Elasticsearch and Logstash so I can try the webhook with Slack. Now Kibana won't start and I suspect that's because I'm using Kibana 4.1 like they suggested in that tutorial.

Now there is a Kibana 4.2 0 on the website but if I change the link in the tutorial to 4.2, it won't find it.

Could someone help me with finding the right package link for Kibana 4.2.0 ??
Thanks :smile:

You can find it here

Hi! Thanks for your answer. I appreciate it but I meant something among the lines of this

echo 'deb stable main' | sudo tee /etc/apt/sources.list.d/kibana.list

if I replace the 4.1 with 4.2 it won't work. I'd be surprised if there wasn't a similar link for Kibana 4.2.0 but if there really isn't then I'll go with what you suggested.

We don't offer this, even the 4.1 that exists now isn't officially supported.

It isn't? Then how do you explain the ""? Its clearly settled on the domain of The link itself works for the purposes I'm used it for so I'd have to disagree unless I'm missing something crucial here.

Basically you can use it but you're on your own until we release properly announced and document repositories.

Well the main reason that I use the deb packages is to avoid troublesome things like "don't run elasticsearch as root user" and it also automatically makes it a service. Though the command I use for those deb packages won't work on the Elasticsearch 2.0 deb release nor on the Logstash 2.0 deb release and like I concluded before, Kibana doesn't even have one on the site.

So sadly I guess that just means tough luck for me.

What command is this?

Continuing the discussion from Package for Kibana 4.2.0:

Well I say command but its actually a few lines.

first: wget -qO - | sudo apt-key add -

second: echo "deb stable main" | sudo tee -a /etc/apt/sources.list.d/elasticsearch-1.7.list

third: sudo apt-get update && sudo apt-get -y install elasticsearch

if I replace the "" with the deb link on the website, it fails, saying 404 not found.

All I'm trying to do here is make a slack watcher haha. The previous version worked rather easily with the e-mail but for some reason I'm having a hard time.

This one worked for me:

echo "deb stable main" | sudo tee -a /etc/apt/sources.list.d/elasticsearch-2.x.list

I would love to see the repo updated with kibana 4.2.0 (of course 4.3.0 would be nice too, but better wait on the release for that one).

@renevdm Thanks for the suggestion but that is the link to elasticsearch. I need the Kibana one :smile:

@alexjhart Yeah same here. I might be just being lazy and all but deb packages install themselves and it often goes smoothly. If I do it, I might just screw up some configuration.

Well, you were talking about this (see below), and that doesn't look like Kibana either. My post was a reply on that post, not the OP.

Hmm true. Could have specified that though haha. Sorry to trouble you.

All fine, no worries :smile:

1 Like