Path: /_xpack/security/_authenticate, params: {pretty=, index=_xpack, id=_authenticate, type=security} org.elasticsearch.index.IndexNotFoundException: no such index


(Rajeshwer rao Madoori) #1

/elasticsearch-setup-passwords interactive

Unexpected response code [404] from calling GET http://172.0.0.1:9200/_xpack/security/_authenticate?pretty

It doesn't look like the X-Pack security feature is enabled on this Elasticsearch node.

Please check if you have enabled X-Pack security in your elasticsearch.yml configuration file.

ERROR: X-Pack Security is disabled by configuration.


(Rajeshwer rao Madoori) #2

curl -XGET http://172.0.0.x:9200/_xpack/security/_authenticate?pretty { "error" : { "root_cause" : [ { "type" : "index_not_found_exception", "reason" : "no such index", "resource.type" : "index_expression", "resource.id" : "_xpack", "index_uuid" : "_na_", "index" : "_xpack" } ], "type" : "index_not_found_exception", "reason" : "no such index", "resource.type" : "index_expression", "resource.id" : "_xpack", "index_uuid" : "_na_", "index" : "_xpack" }, "status" : 404 }


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.