PGP keys fails to install no valid openPGP data found


(Yoram Dagan) #1

Hi,

I am new to the elastic search technology and exploring my option with log analysis using Elastic search.
The first step that I saw in installing Elasticsearch in to install the PGP key as follows:
"wget -qO - https://packages.elasticsearch.org/GPG-KEY-elasticsearch | sudo apt-key add -"

When I run the command I get an erro saying:
GPG: no valid OpenPGP data found.

I didn't succeed to come around this issue.
Can anyone help?

Using Ubuntu 14.04 on a VMWare

Thanks
Yoram


Error on import the Elasticsearch public GPG key into apt
Elasticsearch Installation: gpg: no valid OpenPGP
(Yoram Dagan) #2

Managed to resolve it.
separated the command in to two commands and used directly the file name which was downloaded


(MichaƂ Czeraszkiewicz) #3

Happened to me when I installed wget like this:

apt-get install -y --no-install-recommends wget

Probably your wget can't handle https.


#4

@yoram
Hello
i do have the same error but i can't only do the second part of the command "sudo apt-key add -" there is just nothing happen ...

after a while tera Term is closing the conection and don't let me in again


(system) #5