Elasticsearch Installation: gpg: no valid OpenPGP


(Alex) #1

Hello All,
When trying to install new instance of elasticsearch, I keep getting the below error message.

$ wget -qO - https://artifacts.elastic.co/GPG-KEY-elasticsearch | sudo apt-key add -
gpg: no valid OpenPGP data found.

I've also tried on a new VM with no luck.
OS: Ubuntu Server 16.04

Thank you,
Alex


(Jymit Singh Khondhu) #2

In this thread, a user solved the problem by running the command separately. Perhaps try that?


(Alex) #3

I just tried and it appears the first command goes through but the second gets stuck at a blank line. Am I supposed to just enter "sudo apt-key add -" on a new line?


(Jymit Singh Khondhu) #4

sure do try the second portion after the wget


(Alex) #5

Yeah that's what I tried, the second portion just adds a new blank line on the command line and stays there until I ctrl+c


(Alex) #6

This can be closed. Still wasn't able to get it working so I did a manual install of .deb package with --no-check-certificate and did the hash check

Thank you.


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.