Gpg: no valid OpenPGP data found


I already have an ELK environment running at version 7.13, I'm trying to update to 7.15. But when trying to use the below command:

wget -qO - | sudo apt-key add -

I get this error:

gpg: no valid OpenPGP data found.

Also if I skipped to the second command as this is not a new setup:

sudo apt-get install apt-transport-https

I get this error:

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be upgraded:
1 upgraded, 0 newly installed, 0 to remove and 136 not upgraded.
Need to get 4680 B of archives.
After this operation, 1024 B of additional disk space will be used.
Err:1 focal-updates/universe amd64 apt-transport-https all 2.0.6
  Temporary failure resolving ''
E: Failed to fetch  Temporary failure resolving ''
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

What I tried to resolve this, but failed:

1- successfully pinged from another machine on the network (so it is not an ISP issue.

2- Changed/ Added DNS from to,

3- tried to use each command seperatly:
first wget -qO -
then sudo apt-key add -

Still no luck, any help is really appreciated.

PS: I've upgraded before from 7.10 to 7.13 with same commands successfully with no errors!

I've removed the -q from the command to see wats happening an got this:

 wget -O - | sudo apt-key add -
--2021-12-01 10:22:31--
Resolving ( failed: Temporary failure in name resolution.
wget: unable to resolve host address ‘’
gpg: no valid OpenPGP data found.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.