Pipelines YAML file is empty

I am trying to load a csv file to Elasticsearch using Logstash.
I ran this command:
bin/logstash --path.data file_name.conf
I get this error:

   ERROR: Pipelines YAML file is empty. Location: /home/nerifkh/Downloads/logstash/config/pipelines.yml
  bin/logstash -f CONFIG_PATH [-t] [-r] [] [-w COUNT] [-l LOG]
  bin/logstash -e CONFIG_STR [-t] [--log.level fatal|error|warn|info|debug|trace] [-w COUNT] [-l LOG]
  bin/logstash -i SHELL [--log.level fatal|error|warn|info|debug|trace]
  bin/logstash -V [--log.level fatal|error|warn|info|debug|trace]
  bin/logstash --help
[2018-04-20T11:33:41,112][ERROR][org.logstash.Logstash    ] java.lang.IllegalStateException: org.jruby.exceptions.RaiseException: (SystemExit) exit

Hey @Nfekih,

you must configure the input, filter, output section in your config file, because everything is commented out by default. Otherwise logstash don´t know what to do with your data. If you allready have an existing file please set the path to this file in your startup command with -f path_to_your_conf.

Let me know if you need more help.
Best regards,

1 Like

Hi @PolterFox
it has been three days that I am struggling with these kind of errors.
Now it worked!! I just deleted the logstash file and re-un-tar it. I put the config file in logstash/config and ran this command bin/logstash --path.data filename.conf and it worked fine.
Thank you for your time, much appreciated :slight_smile:
kind regards

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.